summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-01-26 13:01:54 -0800
committerMatt Turner <mattst88@gentoo.org>2020-01-26 13:09:54 -0800
commitae80d3bd2ce0361a868adbf17f82ce0e48723f08 (patch)
tree87c7f26594725fb30deb948c11572d655b3bd52d /dev-util
parentdev-util/spirv-headers: Drop old versions (diff)
downloadgentoo-ae80d3bd2ce0361a868adbf17f82ce0e48723f08.tar.gz
gentoo-ae80d3bd2ce0361a868adbf17f82ce0e48723f08.tar.bz2
gentoo-ae80d3bd2ce0361a868adbf17f82ce0e48723f08.zip
dev-util/spirv-tools: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/spirv-tools/Manifest1
-rw-r--r--dev-util/spirv-tools/files/spirv-tools-2019.1-Fix-vertex-instrumentation.patch113
-rw-r--r--dev-util/spirv-tools/spirv-tools-2019.1-r2.ebuild44
-rw-r--r--dev-util/spirv-tools/spirv-tools-2019.10_pre20191027.ebuild43
4 files changed, 0 insertions, 201 deletions
diff --git a/dev-util/spirv-tools/Manifest b/dev-util/spirv-tools/Manifest
index b0aeec4417ed..4d858e1c34b8 100644
--- a/dev-util/spirv-tools/Manifest
+++ b/dev-util/spirv-tools/Manifest
@@ -1,2 +1 @@
-DIST spirv-tools-2019.1.tar.gz 1493682 BLAKE2B 823b6435fd59a732075073bcecfbfa3081248a2fff21a1375502b812b30a1f988bb32afc41d2f6a6244b4bf37aa9fee2fab710f2cf6d051170e3622d8adf632f SHA512 c528046e1495d58ff0aca773b3b8fa091f943414853cf0344d8e690d868e0df5b1aa66bddbab245c5e52cc2fbaf0a2032a3be518fb8ada7f89b8023fa89776b4
DIST spirv-tools-2019.10_pre20191027.tar.gz 1848978 BLAKE2B 174482c7186569878ec6f3409a68a3e11013b12798ffbbfb94c66ae6cd338a3375330908cfebf0cd3c67901bf9c2459c6e586cf95bbf4fee399504aa9958da66 SHA512 d26480b6c70acbdf63e36fb5ed11ce422b976d48ef85e2be263c3897a4d5181c31fb94c087fa7b20f84446f0059c3bb7eac872a6d1b15a599fdeb2a7924232e4
diff --git a/dev-util/spirv-tools/files/spirv-tools-2019.1-Fix-vertex-instrumentation.patch b/dev-util/spirv-tools/files/spirv-tools-2019.1-Fix-vertex-instrumentation.patch
deleted file mode 100644
index 4ca2c53969a3..000000000000
--- a/dev-util/spirv-tools/files/spirv-tools-2019.1-Fix-vertex-instrumentation.patch
+++ /dev/null
@@ -1,113 +0,0 @@
-From 8d2d66f30c5c25029ac029af2bc9c4aa6979e5bc Mon Sep 17 00:00:00 2001
-From: greg-lunarg <greg@lunarg.com>
-Date: Wed, 16 Jan 2019 16:02:07 -0700
-Subject: [PATCH] Fix vertex instrumentation to use VertexIndex and
- InstanceIndex (#2294)
-
-...instead of VertexId and InstanceId
----
- include/spirv-tools/instrument.hpp | 4 ++--
- source/opt/instrument_pass.cpp | 8 ++++----
- source/opt/ir_context.cpp | 4 ++--
- test/opt/inst_bindless_check_test.cpp | 14 +++++++-------
- 4 files changed, 15 insertions(+), 15 deletions(-)
-
-diff --git a/include/spirv-tools/instrument.hpp b/include/spirv-tools/instrument.hpp
-index 69d1ad259..f8068099c 100644
---- a/include/spirv-tools/instrument.hpp
-+++ b/include/spirv-tools/instrument.hpp
-@@ -75,8 +75,8 @@ static const int kInstCommonOutCnt = 4;
- // error.
- //
- // Vertex Shader Output Record Offsets
--static const int kInstVertOutVertexId = kInstCommonOutCnt;
--static const int kInstVertOutInstanceId = kInstCommonOutCnt + 1;
-+static const int kInstVertOutVertexIndex = kInstCommonOutCnt;
-+static const int kInstVertOutInstanceIndex = kInstCommonOutCnt + 1;
-
- // Frag Shader Output Record Offsets
- static const int kInstFragOutFragCoordX = kInstCommonOutCnt;
-diff --git a/source/opt/instrument_pass.cpp b/source/opt/instrument_pass.cpp
-index 8ba8ce504..6935a43dc 100644
---- a/source/opt/instrument_pass.cpp
-+++ b/source/opt/instrument_pass.cpp
-@@ -168,10 +168,10 @@ void InstrumentPass::GenStageStreamWriteCode(uint32_t stage_idx,
- switch (stage_idx) {
- case SpvExecutionModelVertex: {
- // Load and store VertexId and InstanceId
-- GenBuiltinOutputCode(context()->GetBuiltinVarId(SpvBuiltInVertexId),
-- kInstVertOutVertexId, base_offset_id, builder);
-- GenBuiltinOutputCode(context()->GetBuiltinVarId(SpvBuiltInInstanceId),
-- kInstVertOutInstanceId, base_offset_id, builder);
-+ GenBuiltinOutputCode(context()->GetBuiltinVarId(SpvBuiltInVertexIndex),
-+ kInstVertOutVertexIndex, base_offset_id, builder);
-+ GenBuiltinOutputCode(context()->GetBuiltinVarId(SpvBuiltInInstanceIndex),
-+ kInstVertOutInstanceIndex, base_offset_id, builder);
- } break;
- case SpvExecutionModelGLCompute: {
- // Load and store GlobalInvocationId. Second word is unused; store zero.
-diff --git a/source/opt/ir_context.cpp b/source/opt/ir_context.cpp
-index a2f207c0c..fe69027f8 100644
---- a/source/opt/ir_context.cpp
-+++ b/source/opt/ir_context.cpp
-@@ -669,8 +669,8 @@ uint32_t IRContext::GetBuiltinVarId(uint32_t builtin) {
- reg_type = type_mgr->GetRegisteredType(&v4float_ty);
- break;
- }
-- case SpvBuiltInVertexId:
-- case SpvBuiltInInstanceId:
-+ case SpvBuiltInVertexIndex:
-+ case SpvBuiltInInstanceIndex:
- case SpvBuiltInPrimitiveId:
- case SpvBuiltInInvocationId:
- case SpvBuiltInGlobalInvocationId: {
-diff --git a/test/opt/inst_bindless_check_test.cpp b/test/opt/inst_bindless_check_test.cpp
-index ddafb3dc2..a426ce04c 100644
---- a/test/opt/inst_bindless_check_test.cpp
-+++ b/test/opt/inst_bindless_check_test.cpp
-@@ -1650,7 +1650,7 @@ OpCapability Sampled1D
- OpExtension "SPV_KHR_storage_buffer_storage_class"
- %1 = OpExtInstImport "GLSL.std.450"
- OpMemoryModel Logical GLSL450
--OpEntryPoint Vertex %main "main" %_ %coords2D %gl_VertexID %gl_InstanceID
-+OpEntryPoint Vertex %main "main" %_ %coords2D %gl_VertexIndex %gl_InstanceIndex
- OpSource GLSL 450
- OpName %main "main"
- OpName %lod "lod"
-@@ -1684,8 +1684,8 @@ OpMemberDecorate %_struct_61 0 Offset 0
- OpMemberDecorate %_struct_61 1 Offset 4
- OpDecorate %63 DescriptorSet 7
- OpDecorate %63 Binding 0
--OpDecorate %gl_VertexID BuiltIn VertexId
--OpDecorate %gl_InstanceID BuiltIn InstanceId
-+OpDecorate %gl_VertexIndex BuiltIn VertexIndex
-+OpDecorate %gl_InstanceIndex BuiltIn InstanceIndex
- %void = OpTypeVoid
- %12 = OpTypeFunction %void
- %float = OpTypeFloat 32
-@@ -1730,8 +1730,8 @@ OpDecorate %gl_InstanceID BuiltIn InstanceId
- %uint_2 = OpConstant %uint 2
- %uint_3 = OpConstant %uint 3
- %_ptr_Input_uint = OpTypePointer Input %uint
--%gl_VertexID = OpVariable %_ptr_Input_uint Input
--%gl_InstanceID = OpVariable %_ptr_Input_uint Input
-+%gl_VertexIndex = OpVariable %_ptr_Input_uint Input
-+%gl_InstanceIndex = OpVariable %_ptr_Input_uint Input
- %uint_5 = OpConstant %uint 5
- %uint_6 = OpConstant %uint 6
- %uint_7 = OpConstant %uint 7
-@@ -1819,11 +1819,11 @@ OpStore %81 %55
- %83 = OpIAdd %uint %68 %uint_3
- %84 = OpAccessChain %_ptr_StorageBuffer_uint %63 %uint_1 %83
- OpStore %84 %uint_0
--%87 = OpLoad %uint %gl_VertexID
-+%87 = OpLoad %uint %gl_VertexIndex
- %88 = OpIAdd %uint %68 %uint_4
- %89 = OpAccessChain %_ptr_StorageBuffer_uint %63 %uint_1 %88
- OpStore %89 %87
--%91 = OpLoad %uint %gl_InstanceID
-+%91 = OpLoad %uint %gl_InstanceIndex
- %93 = OpIAdd %uint %68 %uint_5
- %94 = OpAccessChain %_ptr_StorageBuffer_uint %63 %uint_1 %93
- OpStore %94 %91
-
diff --git a/dev-util/spirv-tools/spirv-tools-2019.1-r2.ebuild b/dev-util/spirv-tools/spirv-tools-2019.1-r2.ebuild
deleted file mode 100644
index 9c2530ee05d7..000000000000
--- a/dev-util/spirv-tools/spirv-tools-2019.1-r2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit cmake-multilib cmake-utils python-any-r1
-
-DESCRIPTION="Provides an API and commands for processing SPIR-V modules"
-HOMEPAGE="https://github.com/KhronosGroup/SPIRV-Tools"
-SRC_URI="https://github.com/KhronosGroup/SPIRV-Tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-# Tests fail upon finding symbols that do not match a regular expression
-# in the generated library. Easily hit with non-standard compiler flags
-RESTRICT="test"
-
-COMMON_DEPEND=">=dev-util/spirv-headers-1.3.4_pre20190302"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND=""
-BDEPEND="${PYTHON_DEPS}
- ${COMMON_DEPEND}"
-
-EGIT_COMMIT="2297d4a3dfcbfd2a8b4312fab055ae26e3289fd3"
-S="${WORKDIR}/SPIRV-Tools-${PV}"
-PATCHES=( "${FILESDIR}"/${PN}-2019.1-Fix-vertex-instrumentation.patch )
-
-multilib_src_configure() {
- local mycmakeargs=(
- "-DSPIRV-Headers_SOURCE_DIR=/usr/"
- "-DSPIRV_WERROR=OFF"
- )
-
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- cmake-utils_src_install
- echo "${EGIT_COMMIT}" > "${PN}-commit.h" || die
- insinto /usr/include/"${PN}"
- doins "${PN}-commit.h"
-}
diff --git a/dev-util/spirv-tools/spirv-tools-2019.10_pre20191027.ebuild b/dev-util/spirv-tools/spirv-tools-2019.10_pre20191027.ebuild
deleted file mode 100644
index 4706f482cc77..000000000000
--- a/dev-util/spirv-tools/spirv-tools-2019.10_pre20191027.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit cmake-multilib cmake-utils python-any-r1
-
-DESCRIPTION="Provides an API and commands for processing SPIR-V modules"
-HOMEPAGE="https://github.com/KhronosGroup/SPIRV-Tools"
-EGIT_COMMIT="ec12de9131244a076c34ddca2e8d7451288be7e1"
-SRC_URI="https://github.com/KhronosGroup/SPIRV-Tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# Tests fail upon finding symbols that do not match a regular expression
-# in the generated library. Easily hit with non-standard compiler flags
-RESTRICT="test"
-
-COMMON_DEPEND=">=dev-util/spirv-headers-1.5.1"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND=""
-BDEPEND="${PYTHON_DEPS}
- ${COMMON_DEPEND}"
-
-S="${WORKDIR}/SPIRV-Tools-${EGIT_COMMIT}"
-
-multilib_src_configure() {
- local mycmakeargs=(
- "-DSPIRV-Headers_SOURCE_DIR=/usr/"
- "-DSPIRV_WERROR=OFF"
- )
-
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- cmake-utils_src_install
- echo "${EGIT_COMMIT}" > "${PN}-commit.h" || die
- insinto /usr/include/"${PN}"
- doins "${PN}-commit.h"
-}