summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny <mail@donny.nyc>2021-09-04 12:57:02 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-09-07 13:19:50 +0300
commitb5e080853cf530fc860a28d1130e3a221779eefd (patch)
tree1844c0e066bd34f9fd4bb7244e2d1d222b6188ed /dev-util
parentdev-util/cppunit: revbump 1.15.1-r2 to 1.15.1-r3 (diff)
downloadgentoo-b5e080853cf530fc860a28d1130e3a221779eefd.tar.gz
gentoo-b5e080853cf530fc860a28d1130e3a221779eefd.tar.bz2
gentoo-b5e080853cf530fc860a28d1130e3a221779eefd.zip
dev-util/cppunit: drop 9999 ebuild
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppunit/cppunit-9999.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-util/cppunit/cppunit-9999.ebuild b/dev-util/cppunit/cppunit-9999.ebuild
deleted file mode 100644
index a03be99e2df6..000000000000
--- a/dev-util/cppunit/cppunit-9999.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal
-
-DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/cppunit"
-if [[ "${PV}" == *9999 ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/cppunit.git"
-else
- SRC_URI="https://dev-www.libreoffice.org/src/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-fi
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="doc examples static-libs"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? (
- app-doc/doxygen[dot]
- media-gfx/graphviz
- )
-"
-
-DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
-[[ "${PV}" == 9999 ]] || DOCS+=( ChangeLog )
-
-src_prepare() {
- default
- [[ "${PV}" == 9999 ]] && eautoreconf
-}
-
-src_configure() {
- # Anything else than -O0 breaks on alpha
- use alpha && replace-flags "-O?" -O0
-
- multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-werror
- $(multilib_native_use_enable doc dot)
- $(multilib_native_use_enable doc doxygen)
- $(use_enable static-libs static)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install_all() {
- if use doc ; then
- mv "${ED}"/usr/share/${PN}/html "${ED}"/usr/share/doc/${PF} \
- || die
- rm -r "${ED}"/usr/share/${PN} || die
- fi
- einstalldocs
-
- find "${ED}" -name '*.la' -delete || die
-
- if use examples ; then
- find examples -iname "*.o" -delete
- insinto /usr/share/${PN}
- doins -r examples
- fi
-}