summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-25 06:34:39 +0000
committerSam James <sam@gentoo.org>2023-11-25 06:34:39 +0000
commitb7cdf199cc92df2bb376669cab0419575b04d9d2 (patch)
treedda46fc598420743e0816312fd5d31f9b92c8113 /dev-util
parentnet-analyzer/mtr: drop 0.95 (diff)
downloadgentoo-b7cdf199cc92df2bb376669cab0419575b04d9d2.tar.gz
gentoo-b7cdf199cc92df2bb376669cab0419575b04d9d2.tar.bz2
gentoo-b7cdf199cc92df2bb376669cab0419575b04d9d2.zip
dev-util/sh: drop 3.5.1, 3.6.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/sh/Manifest4
-rw-r--r--dev-util/sh/sh-3.5.1.ebuild54
-rw-r--r--dev-util/sh/sh-3.6.0.ebuild54
3 files changed, 0 insertions, 112 deletions
diff --git a/dev-util/sh/Manifest b/dev-util/sh/Manifest
index d0d043aba5ac..5f386fada8a5 100644
--- a/dev-util/sh/Manifest
+++ b/dev-util/sh/Manifest
@@ -1,6 +1,2 @@
-DIST sh-3.5.1-deps.tar.xz 3113476 BLAKE2B 0998ebeacdd7c882542eea25ad5ab3131211c686ac2ba8040b89897a60ab41ecea7fc0c45f6498eda56a4539550622e2693fed0a6a1ed5ca6af060c40a9aaf97 SHA512 b572f7334e04365d3d685ba8b87fff834fb9823e815152646659d66e92410cab03940b5a32f6eb0634c4a0cce34808d03849d8b97b17fdbec939b305b13878e9
-DIST sh-3.5.1.tar.gz 222608 BLAKE2B a81af092d0f8d0ee7c05240d816a99f044bce3e35d242a815a238a27893db5bfc320efc4a0237ca9ecfa0276e4687152c87f6e0170f5326e2d0a8604f94f6adb SHA512 fd1084921254b70376b3ac47b97e2108308252fa6bd23aff1e59aaefb45a7e01c1738a46ae6f4eb255ecade77fb9659fbc8184d2473e8e4f70e520757bad506d
-DIST sh-3.6.0-deps.tar.xz 3291776 BLAKE2B 63a04877eb69aca3b82cf08cd5b171de7fb9aa46910d5d59e7584f2eac424e52bcefdefffb4216b47ea6760535f298fca5ae5e4db29eef9c66a72ffb880b6ec8 SHA512 01271d1e311ab5d6e89dec4287b18229dcd892b05ee0bbf9917fdc9a9318d3f44e1322ca50722e5771091615dfa12f8041a23d533c7107ed03010d399667a24f
-DIST sh-3.6.0.tar.gz 216645 BLAKE2B a4b9e711eb1d8889e317775fcbab95a273c0bef9ff46ce043c1db39b4b21ca944272b595f60d190bf169ce4924f6c37c9aa1945155e62f9f27c7af2ff9008e3f SHA512 c7812496c66df2fd32b674fc260d0f100b3b6297540bc9e4890d603ca8f41589950493d6d62924bded6d17d4dd9347ee5bc47464608cdcde9c1f73e198c454cd
DIST sh-3.7.0-deps.tar.xz 9776560 BLAKE2B 2376bba34d0b57897f748ce277b8c40da2ac98ad518e516868c442a521b24e4e19016b26dd0e889157781fa75cc7f945dea72a0451937a3bef24d65149d8de7b SHA512 3baf5276b1916e726a99b47dcf1319fb9a015e6096d8dbd430df478f9dbc1ecbcffcb82de72efbb455aa4a6dc17437e00287df27abd2e7e126253171d7024a9e
DIST sh-3.7.0.tar.gz 219380 BLAKE2B 5de1f5576f3e92f5cc892da730b62640b0922f879005e844b3e0b0d84a4e8f1a5f76e89c53152dd3de11c67da20411c5bddd44627ab31b66a72f950b1bf03393 SHA512 5869b68d4bb59907ff7543019e02e8e1efee5963475763b2b2daf0b1ef8621d919d54978a50e52d865b5b76b188c821fecb673e6a9ce42b30cd9907a020e6387
diff --git a/dev-util/sh/sh-3.5.1.ebuild b/dev-util/sh/sh-3.5.1.ebuild
deleted file mode 100644
index ea48ab9e9b7d..000000000000
--- a/dev-util/sh/sh-3.5.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-DESCRIPTION="A shell parser, formatter, and interpreter with bash support"
-HOMEPAGE="https://github.com/mvdan/sh"
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/mvdan/sh.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/mvdan/sh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~x86"
- S="${WORKDIR}/${PN//fmt/}-${PV}"
-fi
-
-LICENSE="Apache-2.0 BSD"
-SLOT="0"
-IUSE="+man"
-
-BDEPEND="man? ( app-text/scdoc )"
-
-src_unpack() {
- default
- if [[ ${PV} == *9999 ]]; then
- git-r3_src_unpack
- go-module_live_vendor
- fi
-}
-
-src_compile() {
- # Not bothering with gosh for now as it's very new
- # https://github.com/mvdan/sh#gosh
- ego build ./cmd/shfmt
- if use man; then
- scdoc <cmd/shfmt/shfmt.1.scd >shfmt.1 || die "conversation of man page failed"
- fi
-}
-
-src_test() {
- cd syntax || die
- ego test -run=-
-}
-
-src_install() {
- dobin shfmt
- if use man; then
- doman shfmt.1
- fi
-}
diff --git a/dev-util/sh/sh-3.6.0.ebuild b/dev-util/sh/sh-3.6.0.ebuild
deleted file mode 100644
index 5fbc2cb45333..000000000000
--- a/dev-util/sh/sh-3.6.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-DESCRIPTION="A shell parser, formatter, and interpreter with bash support"
-HOMEPAGE="https://github.com/mvdan/sh"
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/mvdan/sh.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/mvdan/sh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
- S="${WORKDIR}/${PN//fmt/}-${PV}"
-fi
-
-LICENSE="Apache-2.0 BSD"
-SLOT="0"
-IUSE="+man"
-
-BDEPEND="man? ( app-text/scdoc )"
-
-src_unpack() {
- default
- if [[ ${PV} == *9999 ]]; then
- git-r3_src_unpack
- go-module_live_vendor
- fi
-}
-
-src_compile() {
- # Not bothering with gosh for now as it's very new
- # https://github.com/mvdan/sh#gosh
- ego build ./cmd/shfmt
- if use man; then
- scdoc <cmd/shfmt/shfmt.1.scd >shfmt.1 || die "conversation of man page failed"
- fi
-}
-
-src_test() {
- cd syntax || die
- ego test -run=-
-}
-
-src_install() {
- dobin shfmt
- if use man; then
- doman shfmt.1
- fi
-}