summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2018-10-07 00:34:42 -0400
committerMichał Górny <mgorny@gentoo.org>2018-10-22 22:05:18 +0200
commitf3c23167984c8b7135780be185597ac322330b38 (patch)
tree1d148bcec425d7524205f474a4e48492870b7625 /dev-util
parentdev-util/lcov: update to support live ebuild (diff)
downloadgentoo-f3c23167984c8b7135780be185597ac322330b38.tar.gz
gentoo-f3c23167984c8b7135780be185597ac322330b38.tar.bz2
gentoo-f3c23167984c8b7135780be185597ac322330b38.zip
dev-util/lcov: add version -9999
Closes: https://bugs.gentoo.org/668320 Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/lcov/lcov-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/lcov/lcov-9999.ebuild b/dev-util/lcov/lcov-9999.ebuild
new file mode 100644
index 000000000000..cd55511f0993
--- /dev/null
+++ b/dev-util/lcov/lcov-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/ltp/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-linux ~x64-macos"
+fi
+
+inherit prefix
+
+DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
+HOMEPAGE="http://ltp.sourceforge.net/coverage/lcov.php"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="png"
+
+RDEPEND="
+ dev-lang/perl
+ png? ( dev-perl/GD[png] )
+"
+
+src_prepare() {
+ default
+ if use prefix; then
+ hprefixify bin/*.{pl,sh}
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX="${ED}/usr" CFG_DIR="${ED}/etc" install
+}