summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-04-04 20:39:26 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-04 20:39:52 +0100
commit556a9bd243b9535220ab3cdf6f768c42e244ac32 (patch)
tree8499a73b602ca56d7fae3ac2d6a27e7509087ea0 /dev-vcs/cvs-fast-export
parentgnome-extra/office-runner: EAPI-7 bump (diff)
downloadgentoo-556a9bd243b9535220ab3cdf6f768c42e244ac32.tar.gz
gentoo-556a9bd243b9535220ab3cdf6f768c42e244ac32.tar.bz2
gentoo-556a9bd243b9535220ab3cdf6f768c42e244ac32.zip
dev-vcs/cvs-fast-export: bump up to 1.56
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-vcs/cvs-fast-export')
-rw-r--r--dev-vcs/cvs-fast-export/Manifest1
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.56.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index be1100f14b1a..e918cb572909 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1 +1,2 @@
DIST cvs-fast-export-1.55.tar.gz 478449 BLAKE2B 18a94fe4c143ca72949b469f40d79540aa8b6fc8562bed7e638b7ac4834e6f4be73f1cf0c906f0ea1dfdfadada74fa3b8a1a56c1aeb011467977be2d4ee84fbe SHA512 494b7bdef890c59967a0552b605f2f5b49ff401c791dc260378192babab1a8e13af796f746c52c36d0ff95c94d04f066f31245f803793092bcaf2e63bd367d05
+DIST cvs-fast-export-1.56.tar.gz 492482 BLAKE2B 936f9f448dd6577122ace45380d8726f648fd31ffb9840bd931e343cc6c3f3526e4aa6f8735feb2a49d4d8df5fdb83ea54438e51951ea2be3b1ab221fdc11c33 SHA512 852a13fab095817a9650164c93f11aaeb4ced827489f20bde35baa492f6f125e82c3f35410899978706589105275536d98d973fbf482758ed054b3bbe9e3c581
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.56.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.56.ebuild
new file mode 100644
index 000000000000..45dc138ac582
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.56.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship some tests in tarball
+
+src_prepare() {
+ default
+
+ tc-export CC
+ export prefix="${EPREFIX}"/usr
+
+ # respect CC, CFLAGS and LDFLAGS
+ sed \
+ -e 's/cc /$(CC) $(LDFLAGS) /' \
+ -e 's/^CFLAGS += -O/#&/' \
+ -e 's/CFLAGS=/CFLAGS+=/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ # '.adoc.html' rules can't be executed in parallel
+ # as they reuse the same 'docbook-xsl.css' file name.
+ emake -j1 html
+ # Allow full parallelism for the rest
+ emake
+}
+
+src_install() {
+ default
+ dodoc README.adoc
+}