summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-24 06:53:07 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-24 06:53:07 +0200
commit657202f124f9214334718acb4c57ab4b0324bd8c (patch)
tree8ccd1442a831a40f57046f5315b5960f101606c4 /dev-vcs/cvs2svn
parentnet-p2p/transmission: systemd: Move config-dir to a service.d file (diff)
downloadgentoo-657202f124f9214334718acb4c57ab4b0324bd8c.tar.gz
gentoo-657202f124f9214334718acb4c57ab4b0324bd8c.tar.bz2
gentoo-657202f124f9214334718acb4c57ab4b0324bd8c.zip
dev-vcs/cvs2svn: Revbump/EAPI-bump and conversion to distutils-r1 eclass
with a patch from idella4 in bug #541094. Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs/cvs2svn')
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..8d014b940203
--- /dev/null
+++ b/dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+FILEVER="49237"
+
+DESCRIPTION="Convert a CVS repository to a Subversion repository"
+HOMEPAGE="http://cvs2svn.tigris.org/"
+SRC_URI="http://cvs2svn.tigris.org/files/documents/1462/${FILEVER}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="bazaar git test"
+
+DEPEND=">=dev-vcs/subversion-1.0.9"
+RDEPEND="${DEPEND}
+ bazaar? ( >=dev-vcs/bzr-1.13[${PYTHON_USEDEP}] )
+ git? ( >=dev-vcs/git-1.5.4.4[${PYTHON_USEDEP}] )
+ dev-vcs/rcs"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ python_fix_shebang .
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ emake man
+}
+
+src_install() {
+ distutils-r1_src_install
+ insinto "/usr/share/${PN}"
+ doins -r contrib cvs2{svn,git,bzr}-example.options
+ doman *.1
+}
+
+python_test() {
+ # Need this because subversion is localized, but the tests aren't
+ export LC_ALL=C
+ "${PYTHON}" -W ignore run-tests.py
+}
+
+pkg_postinst() {
+ elog "Additional scripts and examples have been installed to:"
+ elog " /usr/share/${PN}/"
+}