summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-08-12 08:01:33 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-08-12 08:02:30 -0400
commit86c9dd9719d58f940d0eb6f5c0c0974ad7e0ab50 (patch)
treec63f682285e919f081c2770421ae3cd688bce021 /dev-vcs/fossil
parentkde-apps/akonadi: Drop USE=sqlite, cleanup ebuild (diff)
downloadgentoo-86c9dd9719d58f940d0eb6f5c0c0974ad7e0ab50.tar.gz
gentoo-86c9dd9719d58f940d0eb6f5c0c0974ad7e0ab50.tar.bz2
gentoo-86c9dd9719d58f940d0eb6f5c0c0974ad7e0ab50.zip
dev-vcs/fossil: Security Bump to 2.3
Version 2.3 fixes a potential XSS vulnerability on the /help webpage. Gentoo-Bug: 627674 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-vcs/fossil')
-rw-r--r--dev-vcs/fossil/Manifest1
-rw-r--r--dev-vcs/fossil/fossil-2.3.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-vcs/fossil/Manifest b/dev-vcs/fossil/Manifest
index e94fe9be1292..dd58a323f657 100644
--- a/dev-vcs/fossil/Manifest
+++ b/dev-vcs/fossil/Manifest
@@ -1,3 +1,4 @@
DIST fossil-src-1.34.tar.gz 4449452 SHA256 53a6b83e878feced9ac7705f87e5b6ea82727314e3e19202ae1c46c7e4dba49f SHA512 7c2677566527466727e823e5bf59f636b5fd08dd1093a742c3f7f72d398d380288030c3a573ae3c66c60f1e8c194f36f5987fa835251d7ced10533b9779578d7 WHIRLPOOL cb00af705b1f4376e09129091154f847da62817548d1838c03c34422eb223704e8a92cee5038a5cf5f75c600d55ce23fd681ca82f1f0e854b42b23b7c82bc66e
DIST fossil-src-1.35.tar.gz 4642421 SHA256 c1f92f925a87c9872cb40d166f56ba08b90edbab01a8546ff37025836136ba1d SHA512 2a31530d81a316b69daba446e91236fdb94ced17a7228c094fc6053f9d75e736b6a50a93d97b8e875a4750fa4ff868b0dc78b494131b8ed118d160fff8995905 WHIRLPOOL 83406c7010e462f3e9742e03a6eb7a64e5f31516a6d353e56d71a8e54aec2154cd38160e73800ee72d6a5a91a0954e9bb5628b75bf5fd582696507c67a5da803
DIST fossil-src-2.2.tar.gz 4826890 SHA256 9b8f82196eb89e4a2e82b4bcc51e314ae509a22c37073a18a0b325f11c53cf71 SHA512 1a1aedf3f9883a64f9f98c9a01857f5fb69cff0be23817016a4bc405b2efc85f21ac86a771d5e7314128e3fabc21444ac717017cf0935241fd4af964b7c086e0 WHIRLPOOL 8298287694930286f159a59f14efa07f0d3bcdc2ba961c55f7da1faab804e1a5d27386237c6bfa125341bf76bb33e1c3b63e61417378128c7511c459ae6a4705
+DIST fossil-src-2.3.tar.gz 4898441 SHA256 f073abf455a38ea0a08c3926d7445ab8115b145457f36c763ad9b74cd6a64a5d SHA512 41f87a9f79b87895b1972d2866b27205da34076eb35200b60fd38f1921162bf9099a71caac4063c04b919484208b39c7184dff661dc0b5ca7716d8edd11462cc WHIRLPOOL 920144e9a9adf88e9669c0254e924cc6e240e443361638d757910ef198c09659c6e24497f2fae7646285ad6d493d59a09c65bde6523d2c3a9e3af14ff522e456
diff --git a/dev-vcs/fossil/fossil-2.3.ebuild b/dev-vcs/fossil/fossil-2.3.ebuild
new file mode 100644
index 000000000000..f77c89e71296
--- /dev/null
+++ b/dev-vcs/fossil/fossil-2.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/index.html/uv/fossil-src-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug fusefs json legacy-mv-rm -miniz sqlite +ssl static tcl th1-docs th1-hooks"
+
+REQUIRED_USE="ssl? ( !miniz )"
+
+DEPEND="
+ sys-libs/zlib
+ || ( sys-libs/readline:0 dev-libs/libedit )
+ sqlite? ( >=dev-db/sqlite-3.14.0:3 )
+ ssl? ( dev-libs/openssl:0 )
+ tcl? ( dev-lang/tcl:0= )
+"
+RDEPEND="${DEPEND}"
+
+# Tests can't be run from the build directory
+RESTRICT="test"
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf="--with-openssl=$(usex ssl auto none)"
+ use debug && myconf+=' --fossil-debug'
+ use json && myconf+=' --json'
+ use sqlite && myconf+=' --disable-internal-sqlite'
+ use static && myconf+=' --static'
+ use tcl && myconf+=' --with-tcl --with-tcl-stubs'
+
+ local u
+ for u in legacy-mv-rm miniz th1-docs th1-hooks; do
+ use ${u} && myconf+=" --with-${u}"
+ done
+
+ use fusefs || myconf+=' --disable-fusefs'
+
+ tc-export CC
+ ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}