summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-01-20 19:45:17 +0100
committerSebastian Pipping <sping@gentoo.org>2021-01-20 19:47:04 +0100
commit67bc7919f236200112715a4751b1f137b1f7b6fc (patch)
treeddb8082bc9f947b5c7e0e59842af85ee40c661b7 /dev-vcs/git-big-picture
parent*/*: Reassign lordvan's packages (diff)
downloadgentoo-67bc7919f236200112715a4751b1f137b1f7b6fc.tar.gz
gentoo-67bc7919f236200112715a4751b1f137b1f7b6fc.tar.bz2
gentoo-67bc7919f236200112715a4751b1f137b1f7b6fc.zip
dev-vcs/git-big-picture: 1.1.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.12, Repoman-3.0.2
Diffstat (limited to 'dev-vcs/git-big-picture')
-rw-r--r--dev-vcs/git-big-picture/Manifest1
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/git-big-picture/Manifest b/dev-vcs/git-big-picture/Manifest
index b4f5816e4a00..eecba44662ac 100644
--- a/dev-vcs/git-big-picture/Manifest
+++ b/dev-vcs/git-big-picture/Manifest
@@ -1 +1,2 @@
DIST git-big-picture-1.0.0.tar.gz 2952246 BLAKE2B caf28b57399bbdc2c80feda70e2a043dc1a8ffdc1e88bc79ccec44d6857e52726961e5febe9d1dbe1230818990a291900237cc01f65e819995243cbbc47ba8a9 SHA512 3b5416d3802c91ee35ad31ef702ada5f23b33cd77ef4c1f15cf22bb7f7d1e3c315e100aabdca3831b56d52b1d1637afa86382f89f0a2bbc8c60970095cd53d43
+DIST git-big-picture-1.1.1.tar.gz 2960674 BLAKE2B 00b3117f810b78965e5a260000689c3275f078307f8e5ef90e6a032036eeedcda743c6eff3e3a1f53744d71d9b3bf2692efc558d5f5b20eada9a9b2e21559796 SHA512 1bf1b620d73cccb058034bc8920adcab117fbda8b921937aac6b90e2162cf4b334cae934b0395efdf40b5e9a363e7ec69090ca943c839829dedaa40428dbdb13
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild
new file mode 100644
index 000000000000..e83eaba0bc60
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cram[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+
+ distutils_install_for_testing
+ cram test.cram || die "Tests fail with ${EPYTHON}"
+}