summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/git-crypt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/git-crypt')
-rw-r--r--dev-vcs/git-crypt/Manifest3
-rw-r--r--dev-vcs/git-crypt/git-crypt-0.3.ebuild21
-rw-r--r--dev-vcs/git-crypt/git-crypt-0.4.ebuild21
-rw-r--r--dev-vcs/git-crypt/git-crypt-0.5.0.ebuild21
-rw-r--r--dev-vcs/git-crypt/metadata.xml11
5 files changed, 77 insertions, 0 deletions
diff --git a/dev-vcs/git-crypt/Manifest b/dev-vcs/git-crypt/Manifest
new file mode 100644
index 000000000000..81dded219cd1
--- /dev/null
+++ b/dev-vcs/git-crypt/Manifest
@@ -0,0 +1,3 @@
+DIST git-crypt-0.3.tar.gz 20660 SHA256 6b2a03d28240c06ce4c06c3fc73ecd88f61b638e42f8534a9f2d1dbd17132755 SHA512 526630e58a2e74bffe954bc2f489311fb2261337092a1c4462788d9412b7fa7b1aa744402558bba39fe776cfa6333700c4e0ad651d262a7ca14d920485192adc WHIRLPOOL 80a2c9129a0c6bba05418469163a6c32242e84fff1bef4179cf8b60b2bea3f01c6921fa97459e23c3bd08223cfe18f6cf1363f01b5244f0f94689d55954cfa90
+DIST git-crypt-0.4.tar.gz 44146 SHA256 8825200a353ba9fe5f972c67e2ca4f1e7194cd3ad369ba14fddb1ba840dc2140 SHA512 aa146d922258c4a68ad1a211b58e3b1e1b1135661ebecf3ede1b344fc93401eb9d0aa51cfa068f76fab3ab7c936ad6cf46e61e0e9505aaf4f338e54826ae88f6 WHIRLPOOL 8bd32cc735416a2eb3df1f144ccf7e86b09bcdd475f766df4d83885f47ead097614641df95d52e8afbb8c5935bffa7716eeab67b4ee73134c790745bc45d1027
+DIST git-crypt-0.5.0.tar.gz 56694 SHA256 5150144a528bc74eeb47a2884cf2fefe978a1d1dc0223bbfcac395fa6a73a410 SHA512 0ed75e6962d8e8260811e048c22d724bdd63d461615e8f99c1d65a07f931f9630c1b853112f202b612dc69746a9ad03995f2947ad6fa39af56a878d993d65d77 WHIRLPOOL 0fc57344d3a0996572db5b0184611d27f8e6574733d0b7d39f52db17c06f1a2403358ac3da2f0e46cbf0c004446f82c5bedf9082f627f6ce18f5e99462e8b559
diff --git a/dev-vcs/git-crypt/git-crypt-0.3.ebuild b/dev-vcs/git-crypt/git-crypt-0.3.ebuild
new file mode 100644
index 000000000000..2f454f18ff74
--- /dev/null
+++ b/dev-vcs/git-crypt/git-crypt-0.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="transparent file encryption in git"
+HOMEPAGE="https://www.agwa.name/projects/git-crypt/"
+SRC_URI="https://github.com/AGWA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-vcs/git"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ mkdir -p "${D}"/usr/bin
+ emake PREFIX="${D}"/usr install
+}
diff --git a/dev-vcs/git-crypt/git-crypt-0.4.ebuild b/dev-vcs/git-crypt/git-crypt-0.4.ebuild
new file mode 100644
index 000000000000..2f454f18ff74
--- /dev/null
+++ b/dev-vcs/git-crypt/git-crypt-0.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="transparent file encryption in git"
+HOMEPAGE="https://www.agwa.name/projects/git-crypt/"
+SRC_URI="https://github.com/AGWA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-vcs/git"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ mkdir -p "${D}"/usr/bin
+ emake PREFIX="${D}"/usr install
+}
diff --git a/dev-vcs/git-crypt/git-crypt-0.5.0.ebuild b/dev-vcs/git-crypt/git-crypt-0.5.0.ebuild
new file mode 100644
index 000000000000..7413d6813ac4
--- /dev/null
+++ b/dev-vcs/git-crypt/git-crypt-0.5.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="transparent file encryption in git"
+HOMEPAGE="https://www.agwa.name/projects/git-crypt/"
+SRC_URI="https://github.com/AGWA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-vcs/git"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ mkdir -p "${D}"/usr/bin
+ emake PREFIX="${D}"/usr install
+}
diff --git a/dev-vcs/git-crypt/metadata.xml b/dev-vcs/git-crypt/metadata.xml
new file mode 100644
index 000000000000..6536a3256f44
--- /dev/null
+++ b/dev-vcs/git-crypt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">AGWA/git-crypt</remote-id>
+ </upstream>
+</pkgmetadata>