summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-10-12 21:41:24 +0200
committerJohannes Huber <johu@gentoo.org>2016-10-12 21:42:30 +0200
commit57b00bb5766732a4276125a12cda78b57e8a1ac5 (patch)
tree545ebc0a4c01e3b1bb91bb3f707a2ce2a9f5435b /dev-vcs/git-flow
parentdev-util/lorax: add python 3.4 support (diff)
downloadgentoo-57b00bb5766732a4276125a12cda78b57e8a1ac5.tar.gz
gentoo-57b00bb5766732a4276125a12cda78b57e8a1ac5.tar.bz2
gentoo-57b00bb5766732a4276125a12cda78b57e8a1ac5.zip
dev-vcs/git-flow: Version bump 1.10.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-vcs/git-flow')
-rw-r--r--dev-vcs/git-flow/Manifest1
-rw-r--r--dev-vcs/git-flow/git-flow-1.10.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/git-flow/Manifest b/dev-vcs/git-flow/Manifest
index f42172a470c8..0d6a0510fdba 100644
--- a/dev-vcs/git-flow/Manifest
+++ b/dev-vcs/git-flow/Manifest
@@ -1,3 +1,4 @@
DIST git-flow-1.10.0.tar.gz 63175 SHA256 e9c25a500eec3ea6e537a811ed9063e567c5e310caa3ffb274950b744ffcb25a SHA512 5782298dc92a94d673f699fccaa2a00795888f35d613549a2048c84edc0a583bfa1dbf219539745f9c03a1f0cbe8bfcce4a0d9ff596eef397d989060d84b6b92 WHIRLPOOL 7884918c3ccefd76ef46c497ab88cc53d7f034d7ab5514e6bc0c3ae7e21c19778a761bfb111313507bdd31efe73c151eeb10ce268188bfc4f4b113d252a735e4
+DIST git-flow-1.10.2.tar.gz 63275 SHA256 09b9de0790276cbff2906c31193bdac859235a0cdfb56cedd13b4a1a4ee75065 SHA512 139e56eb872a3db271a0e7c65c8d55d2720c06646c2569f14d8e7485d3888918fa8390a95a9df48b4677c1a225367b5aeadf4e7705b9475c38f9e931ea45fe03 WHIRLPOOL 1cb551e9f3f71a5e7b205b57d4c216f3b9bc7afe622de6b6944183baeffdf3fdb59d6e0dd06afe5e06dc3c3c0d0bebf5aa08ce8a5151e1413b01ceec671a2552
DIST git-flow-1.9.1.tar.gz 61800 SHA256 7692c77744663c5243cdd390bef0a621caee92dde228b50ef97149fc1b54780d SHA512 6245ff641452e72490b8d12610bc1352048efc2016000b9a6f466140e06c41b05a9fbea8ec192f106bb790b76b56babca8bb684a5128739873d2f7fafe48ad32 WHIRLPOOL 904867ecc1cd7f52dd48b839046df838f019aa9472b6e7202de562b70cac83203e10f0de7359279d619e4391d8ae3019ff9fa797a91d6b7ea0ed132c21ccaa60
DIST git-flow-completion-0.5.2.tar.gz 7501 SHA256 7d11d82b9a3c25f7c7189ac61d21a4edb2432435d6138f092f49348bb17917df SHA512 500cb6163ebb2bf9b996dd5bcac00efa857badfc95ee1d633f2b16803c6baae7315a96c713107645e0971be4736fe1eef747dc773eb50da138551be4838c21b3 WHIRLPOOL 90eaf0d6adcc87369455129052cbcad9c153fe91892a0607fd311bb370a1004b9f85664d0fb06907369bc6bbe6a224a95981fa5d5518610fab2cade0d33c7957
diff --git a/dev-vcs/git-flow/git-flow-1.10.2.ebuild b/dev-vcs/git-flow/git-flow-1.10.2.ebuild
new file mode 100644
index 000000000000..abdb799f92f3
--- /dev/null
+++ b/dev-vcs/git-flow/git-flow-1.10.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/-/}-avh"
+COMP_PN="${PN}-completion"
+COMP_PV="0.5.2"
+COMP_P="${COMP_PN}-${COMP_PV}"
+inherit bash-completion-r1
+
+DESCRIPTION="Git extensions to provide high-level repository operations"
+HOMEPAGE="https://github.com/petervanderdoes/gitflow-avh"
+SRC_URI="https://github.com/petervanderdoes/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/petervanderdoes/${COMP_PN}/archive/${COMP_PV}.tar.gz -> ${COMP_P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+DOCS=( AUTHORS Changes.mdown README.mdown )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_compile() {
+ true
+}
+
+src_install() {
+ emake prefix="${D}/usr" install
+ einstalldocs
+ newbashcomp "${WORKDIR}/${COMP_P}/${COMP_PN}.bash" ${PN}
+}