summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <nils.freydank@posteo.de>2020-11-10 09:59:11 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-18 17:24:40 +0200
commitf06f97dc9b9fe6e0d57474e0e01ed29de2c9979a (patch)
tree169a4866b97758c63bbbabc882ca2e83917f6ad9 /dev-vcs/git-lfs
parentdev-vcs/git-lfs: Bump to 2.12.1 (diff)
downloadgentoo-f06f97dc9b9fe6e0d57474e0e01ed29de2c9979a.tar.gz
gentoo-f06f97dc9b9fe6e0d57474e0e01ed29de2c9979a.tar.bz2
gentoo-f06f97dc9b9fe6e0d57474e0e01ed29de2c9979a.zip
dev-vcs/git-lfs: Update the live ebuild
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Nils Freydank <holgersson@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/17618 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs/git-lfs')
-rw-r--r--dev-vcs/git-lfs/git-lfs-9999.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/dev-vcs/git-lfs/git-lfs-9999.ebuild b/dev-vcs/git-lfs/git-lfs-9999.ebuild
index a48a6fe6e6c6..f5a948c8f4fd 100644
--- a/dev-vcs/git-lfs/git-lfs-9999.ebuild
+++ b/dev-vcs/git-lfs/git-lfs-9999.ebuild
@@ -13,7 +13,7 @@ if [[ "${PV}" = 9999* ]]; then
inherit git-r3
else
SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
@@ -26,12 +26,13 @@ RDEPEND="dev-vcs/git"
RESTRICT+=" !test? ( test )"
src_compile() {
- set -- go build \
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}" \
- -mod vendor -v -work -x \
- -o git-lfs git-lfs.go
- echo "$@"
- "$@" || die
+ # Flags -w, -s: Omit debugging information to reduce binary size,
+ # see https://golang.org/cmd/link/.
+ local mygobuildargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT} -s -w"
+ -mod vendor -v -work -x
+ )
+ go build "${mygobuildargs[@]}" -o git-lfs git-lfs.go || die
if use doc; then
ronn docs/man/*.ronn || die "man building failed"
@@ -45,12 +46,11 @@ src_install() {
}
src_test() {
- set -- go test \
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}" \
- -mod vendor \
- ./...
- echo "$@"
- "$@" || die
+ local mygotestargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}"
+ -mod vendor
+ )
+ go test "${mygotestargs[@]}" ./... || die
}
pkg_postinst () {