summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/git-merge-changelog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/git-merge-changelog')
-rw-r--r--dev-vcs/git-merge-changelog/Manifest2
-rw-r--r--dev-vcs/git-merge-changelog/git-merge-changelog-20140103.ebuild23
-rw-r--r--dev-vcs/git-merge-changelog/git-merge-changelog-20140223.ebuild25
-rw-r--r--dev-vcs/git-merge-changelog/metadata.xml7
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-vcs/git-merge-changelog/Manifest b/dev-vcs/git-merge-changelog/Manifest
new file mode 100644
index 000000000000..0c0b8e722927
--- /dev/null
+++ b/dev-vcs/git-merge-changelog/Manifest
@@ -0,0 +1,2 @@
+DIST git-merge-changelog-20140103.tar.xz 299628 SHA256 d3f0694ca65c765a39b5d2381a2c9d735d16d29bef1737fdf38e9d44bcd3ef29 SHA512 cc3287424313f3c3590bbc67ac2615c69154001019915163b59d4600b320abeaf1e72baac7fd53dd2906be16149ce9a325db0b8966bb024db18f4d11b86fd405 WHIRLPOOL 1689456ebc076bbc3e97beb6f63f91bf857a5493ce29b2fd3dea5667891cd6db01f5b30dbdbea510701c153949f1f0287e966af419846be1df06f493523d8fe5
+DIST git-merge-changelog-20140223.tar.xz 298332 SHA256 75a584cee054cafcb1ab7b71dc3beee33b39ea30b50dace48f044ee788560482 SHA512 ea5fcb0a0839e37976e333dc773d0bca43a1fce4821af08c5baba8e5783e129f8b4de4efd4b1b3399a7c1d3796e4094916843ac2d360d81396d67f571e020638 WHIRLPOOL 41182891e268e0ade060cac261d230fda2534fa53aebb40ea2b44e62cef1d5bef69ba9d7a7f6839c4b24135b1012d29f43886b9729fdd801173c2a8c240b3809
diff --git a/dev-vcs/git-merge-changelog/git-merge-changelog-20140103.ebuild b/dev-vcs/git-merge-changelog/git-merge-changelog-20140103.ebuild
new file mode 100644
index 000000000000..042ff976d50f
--- /dev/null
+++ b/dev-vcs/git-merge-changelog/git-merge-changelog-20140103.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Git merge driver for GNU style ChangeLog files"
+HOMEPAGE="http://www.gnu.org/software/gnulib/"
+# snapshot extracted from git://git.savannah.gnu.org/gnulib.git using
+# ./gnulib-tool --create-testdir --without-tests --dir=${PN} ${PN};
+# cd ${PN}; ./configure; make maintainer-clean
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -n '/README/{h;:x;n;/^#/!{H;bx};g;s/\n*$//;s:/usr/local:/usr:g;p;q}' \
+ gllib/git-merge-changelog.c >README || die
+}
diff --git a/dev-vcs/git-merge-changelog/git-merge-changelog-20140223.ebuild b/dev-vcs/git-merge-changelog/git-merge-changelog-20140223.ebuild
new file mode 100644
index 000000000000..af48bbd91497
--- /dev/null
+++ b/dev-vcs/git-merge-changelog/git-merge-changelog-20140223.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# snapshot extracted from git://git.savannah.gnu.org/gnulib.git using
+# ./gnulib-tool --create-testdir --without-tests --dir=${PN} ${PN};
+# cd ${PN}; ./configure; make maintainer-clean
+
+EAPI=5
+
+DESCRIPTION="Git merge driver for GNU style ChangeLog files"
+HOMEPAGE="http://www.gnu.org/software/gnulib/"
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -n "/README/{h;:x;n;/^#/!{H;bx};g;s/\n*$//;s:/usr/local:${EPREFIX}/usr:g;p;q}" \
+ gllib/git-merge-changelog.c >README || die
+}
diff --git a/dev-vcs/git-merge-changelog/metadata.xml b/dev-vcs/git-merge-changelog/metadata.xml
new file mode 100644
index 000000000000..e153d85b2356
--- /dev/null
+++ b/dev-vcs/git-merge-changelog/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>ulm@gentoo.org</email>
+</maintainer>
+</pkgmetadata>