summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-20 16:41:46 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-20 16:41:46 +0200
commit56312573763e794982d7a7284e7e7d1a8a9f8eaa (patch)
tree515adaff98e1ae07746d09ff17bdc6bfada5eaaa /dev-vcs/git/git-9999-r3.ebuild
parentnet-ftp/pure-ftpd: Drop "need net" dependency in openrc init script (diff)
downloadgentoo-56312573763e794982d7a7284e7e7d1a8a9f8eaa.tar.gz
gentoo-56312573763e794982d7a7284e7e7d1a8a9f8eaa.tar.bz2
gentoo-56312573763e794982d7a7284e7e7d1a8a9f8eaa.zip
dev-vcs/git: Build/install some more man-pages without USE="doc"
Thanks-to: Cornelius Weig <bitte.keine.werbung.einwerfen@googlemail.com> Bug: https://bugs.gentoo.org/517794 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs/git/git-9999-r3.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 5b1ca9489df3..f9275181c5c0 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -363,9 +363,10 @@ src_compile() {
use iconv && use !elibc_glibc && nlsiconv+=( -liconv )
git_emake EXTLIBS="${EXTLIBS} ${nlsiconv[@]}" \
|| die "emake svn-fe failed"
+ git_emake svn-fe.1 || die "emake svn-fe.1 failed"
if use doc ; then
- git_emake svn-fe.{1,html} \
- || die "emake svn-fe.1 svn-fe.html failed"
+ git_emake svn-fe.html \
+ || die "svn-fe.html failed"
fi
popd &>/dev/null || die
fi
@@ -377,8 +378,8 @@ src_compile() {
fi
pushd contrib/subtree &>/dev/null || die
- git_emake
- use doc && git_emake doc
+ git_emake git-subtree{,.1}
+ use doc && git_emake git-subtree.html
popd &>/dev/null || die
pushd contrib/diff-highlight &>/dev/null || die
@@ -394,9 +395,7 @@ src_compile() {
}
src_install() {
- git_emake \
- install || \
- die "make install failed"
+ git_emake install || die "make install failed"
if [[ ${CHOST} == *-darwin* ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
@@ -446,9 +445,9 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install || die "Failed to emake install git-subtree"
+ git_emake install install-man || die "Failed to emake install install-man git-subtree"
if use doc ; then
- git_emake install-man install-doc || die "Failed to emake install-doc install-mangit-subtree"
+ git_emake install-html || die "Failed to emake install-html git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -483,9 +482,9 @@ src_install() {
if use subversion ; then
pushd contrib/svn-fe &>/dev/null || die
dobin svn-fe
+ doman svn-fe.1
dodoc svn-fe.txt
if use doc ; then
- doman svn-fe.1
docinto html
dodoc svn-fe.html
fi