summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-08-12 18:33:51 -0700
committerMatt Turner <mattst88@gentoo.org>2019-08-16 15:58:05 -0700
commita83ca7c3fe8c4e0c700386a12066da5c2f8b4107 (patch)
treedc4680ad87ef3031bf43098b7a7bd737567a3ee4 /dev-vcs/git/git-9999-r3.ebuild
parentdev-libs/libgit2: arm64 stable (bug #692166) (diff)
downloadgentoo-a83ca7c3fe8c4e0c700386a12066da5c2f8b4107.tar.gz
gentoo-a83ca7c3fe8c4e0c700386a12066da5c2f8b4107.tar.bz2
gentoo-a83ca7c3fe8c4e0c700386a12066da5c2f8b4107.zip
dev-vcs/git: Replace USE=+python with USE=perforce
Acked by Lars Wendler on IRC. Closes: https://bugs.gentoo.org/692030 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-vcs/git/git-9999-r3.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index d691700475c6..f3b738828c17 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -51,7 +51,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit perforce +perl ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -99,7 +99,7 @@ RDEPEND="${CDEPEND}
dev-perl/TermReadKey
)
)
- python? ( ${PYTHON_DEPS} )
+ perforce? ( ${PYTHON_DEPS} )
"
# This is how info docs are created with Git:
@@ -133,7 +133,7 @@ REQUIRED_USE="
subversion? ( perl )
webdav? ( curl )
pcre-jit? ( pcre )
- python? ( ${PYTHON_REQUIRED_USE} )
+ perforce? ( ${PYTHON_REQUIRED_USE} )
"
PATCHES=(
@@ -152,7 +152,7 @@ pkg_setup() {
ewarn "with USE=dso, there may be weird crashes in git-svn. You"
ewarn "have been warned."
fi
- if use python ; then
+ if use perforce ; then
python-single-r1_pkg_setup
fi
}
@@ -167,7 +167,7 @@ exportmakeopts() {
$(usex iconv '' NO_ICONV=YesPlease)
$(usex nls '' NO_GETTEXT=YesPlease)
$(usex perl 'INSTALLDIRS=vendor NO_PERL_CPAN_FALLBACKS=YesPlease' NO_PERL=YesPlease)
- $(usex python '' NO_PYTHON=YesPlease)
+ $(usex perforce '' NO_PYTHON=YesPlease)
$(usex subversion '' NO_SVN_TESTS=YesPlease)
$(usex threads '' NO_PTHREAD=YesPlease)
$(usex tk '' NO_TCLTK=YesPlease)
@@ -302,7 +302,7 @@ src_prepare() {
git_emake() {
# bug #320647: PYTHON_PATH
local PYTHON_PATH=""
- use python && PYTHON_PATH="${PYTHON}"
+ use perforce && PYTHON_PATH="${PYTHON}"
emake ${MY_MAKEOPTS} \
prefix="${EPREFIX}"/usr \
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \