summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-24 13:17:24 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-24 13:17:42 +0200
commitb79e40dcfe1e580f77830d2fbdf037433c4d81b6 (patch)
tree3ab88f321b3471d73c2033d3074d4cc692428749 /dev-vcs/git/git-9999-r3.ebuild
parentx11-drivers/nvidia-drivers: Version 430.09 (diff)
downloadgentoo-b79e40dcfe1e580f77830d2fbdf037433c4d81b6.tar.gz
gentoo-b79e40dcfe1e580f77830d2fbdf037433c4d81b6.tar.bz2
gentoo-b79e40dcfe1e580f77830d2fbdf037433c4d81b6.zip
dev-vcs/git: Fixed build on uclibc systems with USE="iconv"
Thanks-to: René Rhéaume <rene.rheaume@gmail.com> Closes: https://bugs.gentoo.org/557122 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs/git/git-9999-r3.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 5d6ae9ba9b66..62eaae028495 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -241,8 +241,10 @@ exportmakeopts() {
# Bug 290465:
# builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
- [[ "${CHOST}" == *-uclibc* ]] && \
+ if [[ "${CHOST}" == *-uclibc* ]] ; then
myopts+=( NO_NSEC=YesPlease )
+ use iconv && myopts+=( NEEDS_LIBICONV=YesPlease )
+ fi
export MY_MAKEOPTS="${myopts[@]}"
export EXTLIBS="${extlibs[@]}"