summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-14 14:28:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-14 14:28:37 +0100
commit368cf8c604417576891a8f2efe1d33eab7f246dd (patch)
tree3fee33251be55ee5bda01886622581503940760c /dev-vcs/git
parentsys-kernel/vanilla-sources: Automated version bump to {3.2.99,3.16.54,4.9.81}... (diff)
downloadgentoo-368cf8c604417576891a8f2efe1d33eab7f246dd.tar.gz
gentoo-368cf8c604417576891a8f2efe1d33eab7f246dd.tar.bz2
gentoo-368cf8c604417576891a8f2efe1d33eab7f246dd.zip
dev-vcs/git: Minor adjustments in src_test()
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/git-2.16.1.ebuild14
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild14
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild14
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild14
-rw-r--r--dev-vcs/git/git-9999.ebuild14
5 files changed, 35 insertions, 35 deletions
diff --git a/dev-vcs/git/git-2.16.1.ebuild b/dev-vcs/git/git-2.16.1.ebuild
index 67a7f811554e..e9f0c242bcf6 100644
--- a/dev-vcs/git/git-2.16.1.ebuild
+++ b/dev-vcs/git/git-2.16.1.ebuild
@@ -572,7 +572,7 @@ src_install() {
}
src_test() {
- local disabled="t9128-git-svn-cmd-branch.sh"
+ local disabled=""
local tests_cvs="t9200-git-cvsexportcommit.sh \
t9400-git-cvsserver-server.sh \
t9401-git-cvsserver-crlf.sh \
@@ -603,7 +603,7 @@ src_test() {
# Unzip is used only for the testcase code, not by any normal parts of Git.
if ! has_version app-arch/unzip ; then
einfo "Disabling tar-tree tests"
- disabled="${disabled} t5000-tar-tree.sh"
+ disabled+=" t5000-tar-tree.sh"
fi
cvs=0
@@ -612,10 +612,10 @@ src_test() {
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
einfo "Skipping other tests that require being non-root"
- disabled="${disabled} ${tests_nonroot}"
+ disabled+=" ${tests_nonroot}"
else
[[ $cvs -gt 0 ]] && \
has_version dev-vcs/cvs && \
@@ -625,17 +625,17 @@ src_test() {
let cvs=$cvs+1
if [[ $cvs -lt 3 ]]; then
einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
fi
if ! use perl ; then
einfo "Disabling tests that need Perl"
- disabled="${disabled} ${tests_perl}"
+ disabled+=" ${tests_perl}"
fi
einfo "Disabling tests that fail with SVN 1.7"
- disabled="${disabled} ${test_svn}"
+ disabled+=" ${test_svn}"
# Reset all previously disabled tests
cd "${S}/t"
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 67a7f811554e..e9f0c242bcf6 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -572,7 +572,7 @@ src_install() {
}
src_test() {
- local disabled="t9128-git-svn-cmd-branch.sh"
+ local disabled=""
local tests_cvs="t9200-git-cvsexportcommit.sh \
t9400-git-cvsserver-server.sh \
t9401-git-cvsserver-crlf.sh \
@@ -603,7 +603,7 @@ src_test() {
# Unzip is used only for the testcase code, not by any normal parts of Git.
if ! has_version app-arch/unzip ; then
einfo "Disabling tar-tree tests"
- disabled="${disabled} t5000-tar-tree.sh"
+ disabled+=" t5000-tar-tree.sh"
fi
cvs=0
@@ -612,10 +612,10 @@ src_test() {
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
einfo "Skipping other tests that require being non-root"
- disabled="${disabled} ${tests_nonroot}"
+ disabled+=" ${tests_nonroot}"
else
[[ $cvs -gt 0 ]] && \
has_version dev-vcs/cvs && \
@@ -625,17 +625,17 @@ src_test() {
let cvs=$cvs+1
if [[ $cvs -lt 3 ]]; then
einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
fi
if ! use perl ; then
einfo "Disabling tests that need Perl"
- disabled="${disabled} ${tests_perl}"
+ disabled+=" ${tests_perl}"
fi
einfo "Disabling tests that fail with SVN 1.7"
- disabled="${disabled} ${test_svn}"
+ disabled+=" ${test_svn}"
# Reset all previously disabled tests
cd "${S}/t"
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 67a7f811554e..e9f0c242bcf6 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -572,7 +572,7 @@ src_install() {
}
src_test() {
- local disabled="t9128-git-svn-cmd-branch.sh"
+ local disabled=""
local tests_cvs="t9200-git-cvsexportcommit.sh \
t9400-git-cvsserver-server.sh \
t9401-git-cvsserver-crlf.sh \
@@ -603,7 +603,7 @@ src_test() {
# Unzip is used only for the testcase code, not by any normal parts of Git.
if ! has_version app-arch/unzip ; then
einfo "Disabling tar-tree tests"
- disabled="${disabled} t5000-tar-tree.sh"
+ disabled+=" t5000-tar-tree.sh"
fi
cvs=0
@@ -612,10 +612,10 @@ src_test() {
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
einfo "Skipping other tests that require being non-root"
- disabled="${disabled} ${tests_nonroot}"
+ disabled+=" ${tests_nonroot}"
else
[[ $cvs -gt 0 ]] && \
has_version dev-vcs/cvs && \
@@ -625,17 +625,17 @@ src_test() {
let cvs=$cvs+1
if [[ $cvs -lt 3 ]]; then
einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
fi
if ! use perl ; then
einfo "Disabling tests that need Perl"
- disabled="${disabled} ${tests_perl}"
+ disabled+=" ${tests_perl}"
fi
einfo "Disabling tests that fail with SVN 1.7"
- disabled="${disabled} ${test_svn}"
+ disabled+=" ${test_svn}"
# Reset all previously disabled tests
cd "${S}/t"
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 67a7f811554e..e9f0c242bcf6 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -572,7 +572,7 @@ src_install() {
}
src_test() {
- local disabled="t9128-git-svn-cmd-branch.sh"
+ local disabled=""
local tests_cvs="t9200-git-cvsexportcommit.sh \
t9400-git-cvsserver-server.sh \
t9401-git-cvsserver-crlf.sh \
@@ -603,7 +603,7 @@ src_test() {
# Unzip is used only for the testcase code, not by any normal parts of Git.
if ! has_version app-arch/unzip ; then
einfo "Disabling tar-tree tests"
- disabled="${disabled} t5000-tar-tree.sh"
+ disabled+=" t5000-tar-tree.sh"
fi
cvs=0
@@ -612,10 +612,10 @@ src_test() {
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
einfo "Skipping other tests that require being non-root"
- disabled="${disabled} ${tests_nonroot}"
+ disabled+=" ${tests_nonroot}"
else
[[ $cvs -gt 0 ]] && \
has_version dev-vcs/cvs && \
@@ -625,17 +625,17 @@ src_test() {
let cvs=$cvs+1
if [[ $cvs -lt 3 ]]; then
einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
fi
if ! use perl ; then
einfo "Disabling tests that need Perl"
- disabled="${disabled} ${tests_perl}"
+ disabled+=" ${tests_perl}"
fi
einfo "Disabling tests that fail with SVN 1.7"
- disabled="${disabled} ${test_svn}"
+ disabled+=" ${test_svn}"
# Reset all previously disabled tests
cd "${S}/t"
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 67a7f811554e..e9f0c242bcf6 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -572,7 +572,7 @@ src_install() {
}
src_test() {
- local disabled="t9128-git-svn-cmd-branch.sh"
+ local disabled=""
local tests_cvs="t9200-git-cvsexportcommit.sh \
t9400-git-cvsserver-server.sh \
t9401-git-cvsserver-crlf.sh \
@@ -603,7 +603,7 @@ src_test() {
# Unzip is used only for the testcase code, not by any normal parts of Git.
if ! has_version app-arch/unzip ; then
einfo "Disabling tar-tree tests"
- disabled="${disabled} t5000-tar-tree.sh"
+ disabled+=" t5000-tar-tree.sh"
fi
cvs=0
@@ -612,10 +612,10 @@ src_test() {
if [[ $cvs -eq 1 ]]; then
ewarn "Skipping CVS tests because CVS does not work as root!"
ewarn "You should retest with FEATURES=userpriv!"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
einfo "Skipping other tests that require being non-root"
- disabled="${disabled} ${tests_nonroot}"
+ disabled+=" ${tests_nonroot}"
else
[[ $cvs -gt 0 ]] && \
has_version dev-vcs/cvs && \
@@ -625,17 +625,17 @@ src_test() {
let cvs=$cvs+1
if [[ $cvs -lt 3 ]]; then
einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"
- disabled="${disabled} ${tests_cvs}"
+ disabled+=" ${tests_cvs}"
fi
fi
if ! use perl ; then
einfo "Disabling tests that need Perl"
- disabled="${disabled} ${tests_perl}"
+ disabled+=" ${tests_perl}"
fi
einfo "Disabling tests that fail with SVN 1.7"
- disabled="${disabled} ${test_svn}"
+ disabled+=" ${test_svn}"
# Reset all previously disabled tests
cd "${S}/t"