summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2019-03-01 15:22:43 -0700
committerChristoph Junghans <junghans@gentoo.org>2019-03-01 15:24:25 -0700
commit56c627b0c8129990685b070d471ff166f15fbe75 (patch)
tree5897639691ce6e165bfe591e4f371f85af211249 /dev-vcs/hg-fast-export
parentdev-python/python-pluginloader: initial commit (diff)
downloadgentoo-56c627b0c8129990685b070d471ff166f15fbe75.tar.gz
gentoo-56c627b0c8129990685b070d471ff166f15fbe75.tar.bz2
gentoo-56c627b0c8129990685b070d471ff166f15fbe75.zip
dev-vcs/hg-fast-export: version bump
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'dev-vcs/hg-fast-export')
-rw-r--r--dev-vcs/hg-fast-export/Manifest1
-rw-r--r--dev-vcs/hg-fast-export/hg-fast-export-190107.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/hg-fast-export/Manifest b/dev-vcs/hg-fast-export/Manifest
index 497e7a8f9b9b..08115cbaa4e2 100644
--- a/dev-vcs/hg-fast-export/Manifest
+++ b/dev-vcs/hg-fast-export/Manifest
@@ -1 +1,2 @@
DIST hg-fast-export-160914.tar.gz 11379 BLAKE2B b751fd954af7a69430459c27dc1948d82aa7abd71db48fcdb98bb0d1b8151910b3417723d2acac1192d26b7f8dde98739b24fd90833fae5d123408293a4c274a SHA512 9e57e7835cc50e8db5d2ebf840d60b4ce25ec19e9722e705eba1178cc41fde57129664de3e1fc157ce8352632c8d0b8be33109afa50b53e159793a8a2ed21fea
+DIST hg-fast-export-190107.tar.gz 17774 BLAKE2B f490c59299d2e486b2b8854cba10630a7b6ebec60bb5f71d342c537e7fee9df3c2bda9264b9e3f865fb0d50bdd0fa1cf125611a2b890c5d79e947d905e4d14f9 SHA512 5449aeb717e1e550fb4c4908be994cb642d4ac2947bda3ae50a9f4024c48426f5b07438081800882000797aa181ccfcb304dfcf18c079ee91c9645bd20b583fd
diff --git a/dev-vcs/hg-fast-export/hg-fast-export-190107.ebuild b/dev-vcs/hg-fast-export/hg-fast-export-190107.ebuild
new file mode 100644
index 000000000000..df39ee8c1cb9
--- /dev/null
+++ b/dev-vcs/hg-fast-export/hg-fast-export-190107.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 vcs-snapshot
+
+DESCRIPTION="mercurial to git converter using git-fast-import"
+HOMEPAGE="https://github.com/frej/fast-export"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+ dev-vcs/mercurial
+ dev-python/python-pluginloader[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -e '/^PYTHON/s/python2\?/python2.7/' \
+ -e '/^PYTHON/s/PYTHON:/E&/g' \
+ -e "/^ROOT/s:=.*:='${EPREFIX}/usr/bin':" \
+ -i "${PN}".sh hg-reset.sh || die
+}
+
+src_install() {
+ default
+ newbin "${PN}".sh "${PN}"
+ newbin hg-reset.sh hg-reset
+ python_foreach_impl python_doexe "${PN}".py
+ python_foreach_impl python_doexe hg-reset.py
+ python_foreach_impl python_domodule hg2git.py
+}