summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-05-20 21:59:31 +0200
committerFabian Groffen <grobian@gentoo.org>2018-05-20 21:59:31 +0200
commit7b31e3c643ada2b277aec10c7142c34ca113f1d1 (patch)
treeb3052452e468362570925f941119a2ff39113d09 /dev-vcs/hg-git/hg-git-0.8.11.ebuild
parentmedia-libs/x264: Drop old (diff)
downloadgentoo-7b31e3c643ada2b277aec10c7142c34ca113f1d1.tar.gz
gentoo-7b31e3c643ada2b277aec10c7142c34ca113f1d1.tar.bz2
gentoo-7b31e3c643ada2b277aec10c7142c34ca113f1d1.zip
dev-vcs/hg-git: version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-vcs/hg-git/hg-git-0.8.11.ebuild')
-rw-r--r--dev-vcs/hg-git/hg-git-0.8.11.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/hg-git-0.8.11.ebuild b/dev-vcs/hg-git/hg-git-0.8.11.ebuild
new file mode 100644
index 000000000000..c8f0f56632ed
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.8.11.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="http://hg-git.github.io https://pypi.org/project/hg-git/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.9.7[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"