summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <dirkjan@ochtman.nl>2016-05-13 12:09:40 +0200
committerDirkjan Ochtman <dirkjan@ochtman.nl>2016-05-13 12:09:40 +0200
commit1ba383b2ead494d913c191b028014446a478c836 (patch)
tree53dc689972cd4ba3b094317e4cab28fe8700e9e6 /dev-vcs/hgsubversion
parentdev-vcs/hgsubversion: remove old versions (diff)
downloadgentoo-1ba383b2ead494d913c191b028014446a478c836.tar.gz
gentoo-1ba383b2ead494d913c191b028014446a478c836.tar.bz2
gentoo-1ba383b2ead494d913c191b028014446a478c836.zip
dev-vcs/hgsubversion: update live ebuild
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-vcs/hgsubversion')
-rw-r--r--dev-vcs/hgsubversion/hgsubversion-9999.ebuild35
1 files changed, 10 insertions, 25 deletions
diff --git a/dev-vcs/hgsubversion/hgsubversion-9999.ebuild b/dev-vcs/hgsubversion/hgsubversion-9999.ebuild
index 3b08abfa989f..9f901ad67276 100644
--- a/dev-vcs/hgsubversion/hgsubversion-9999.ebuild
+++ b/dev-vcs/hgsubversion/hgsubversion-9999.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
-inherit distutils mercurial
+inherit distutils-r1 mercurial
DESCRIPTION="hgsubversion is a Mercurial extension for working with Subversion repositories"
HOMEPAGE="https://bitbucket.org/durin42/hgsubversion/wiki/Home https://pypi.python.org/pypi/hgsubversion"
@@ -19,25 +17,12 @@ SLOT="0"
KEYWORDS=""
IUSE="test"
-RDEPEND="
- >=dev-vcs/mercurial-1.4
+RDEPEND="dev-vcs/mercurial[${PYTHON_USEDEP}]
|| (
- dev-python/subvertpy
+ dev-python/subvertpy[${PYTHON_USEDEP}]
>=dev-vcs/subversion-1.5[python]
- )
-"
-DEPEND="
- dev-python/setuptools
- test? ( dev-python/nose )
-"
+ )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-DOCS="README"
-
-src_test() {
- cd tests
-
- testing() {
- PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" run.py
- }
- python_execute_function testing
-}
+DOCS=( README )