summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2019-01-31 17:51:29 -0600
committerWilliam Hubbs <williamh@gentoo.org>2019-01-31 17:52:47 -0600
commit6a198e14ecb955caf89346c567f22a290abe06b2 (patch)
tree54e6f70b26aa5d4e5adb63c75ce31b5d37a58382 /dev-vcs/python-gitlab
parentRevert "net-misc/openssh: Removed old." (diff)
downloadgentoo-6a198e14ecb955caf89346c567f22a290abe06b2.tar.gz
gentoo-6a198e14ecb955caf89346c567f22a290abe06b2.tar.bz2
gentoo-6a198e14ecb955caf89346c567f22a290abe06b2.zip
dev-vcs/python-gitlab: python command line interface to the gitlab API
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs/python-gitlab')
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/metadata.xml8
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild41
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
new file mode 100644
index 000000000000..e05c6e1a3b68
--- /dev/null
+++ b/dev-vcs/python-gitlab/Manifest
@@ -0,0 +1 @@
+DIST python-gitlab-1.7.0.tar.gz 110657 BLAKE2B 1003d3373d3ef5474b1d5c10b1c6af57e7467cec432fc1eb75b4e1ba7766361641f25461ac2bf1b7692dab855d4e5cbc204240ede3568e71ed1af75682807fb0 SHA512 ad50d989e27948ff5188f4191ad3b7f1e1b45608627b2042bf02d635b2aa8da0a24f6b0383f483a01df54e4ab14576e7e4252576b9c2bdf67a187ae6aad69d53
diff --git a/dev-vcs/python-gitlab/metadata.xml b/dev-vcs/python-gitlab/metadata.xml
new file mode 100644
index 000000000000..c36c37139fad
--- /dev/null
+++ b/dev-vcs/python-gitlab/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild
new file mode 100644
index 000000000000..2ee27c73fd03
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testrepository[${PYTHON_USEDEP}]
+ dev-python/hacking[${PYTHON_USEDEP}]
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3
+ dev-python/sphinx_rtd_theme )"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}