summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2020-02-19 18:42:46 -0500
committerMike Frysinger <vapier@gentoo.org>2020-02-19 18:42:52 -0500
commit8f9b20902029858d5f2b55dfd5ab4a6ed3768c78 (patch)
treecb4bc6c1a44992031a05324556147891b8339390 /dev-vcs/repo/repo-1.27.ebuild
parentdev-libs/libgusb: default enable USE=vala (diff)
downloadgentoo-8f9b20902029858d5f2b55dfd5ab4a6ed3768c78.tar.gz
gentoo-8f9b20902029858d5f2b55dfd5ab4a6ed3768c78.tar.bz2
gentoo-8f9b20902029858d5f2b55dfd5ab4a6ed3768c78.zip
dev-vcs/repo: add 1.27 for frozen python2 branch
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'dev-vcs/repo/repo-1.27.ebuild')
-rw-r--r--dev-vcs/repo/repo-1.27.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-vcs/repo/repo-1.27.ebuild b/dev-vcs/repo/repo-1.27.ebuild
new file mode 100644
index 000000000000..280f73384ee7
--- /dev/null
+++ b/dev-vcs/repo/repo-1.27.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. They are confusingly different currently.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}