summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-01-31 20:41:09 +0100
committerSebastian Pipping <sping@gentoo.org>2021-01-31 20:41:58 +0100
commit079a52b67179ed58b9cdfa022179e36c7ae81cb9 (patch)
treedfef5e705b8d34621f6d3c228998b2c41151a5ac /dev-vcs/rsvndump
parentapp-crypt/nitrokey-app: Remove old 1.4-r1 (diff)
downloadgentoo-079a52b67179ed58b9cdfa022179e36c7ae81cb9.tar.gz
gentoo-079a52b67179ed58b9cdfa022179e36c7ae81cb9.tar.bz2
gentoo-079a52b67179ed58b9cdfa022179e36c7ae81cb9.zip
dev-vcs/rsvndump: Fix linking with lld for profile 17.1
Closes: https://bugs.gentoo.org/739028 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.14, Repoman-3.0.2
Diffstat (limited to 'dev-vcs/rsvndump')
-rw-r--r--dev-vcs/rsvndump/rsvndump-0.6-r1.ebuild14
-rw-r--r--dev-vcs/rsvndump/rsvndump-0.6.ebuild27
2 files changed, 13 insertions, 28 deletions
diff --git a/dev-vcs/rsvndump/rsvndump-0.6-r1.ebuild b/dev-vcs/rsvndump/rsvndump-0.6-r1.ebuild
index 71017a0a6705..f47e6734fe68 100644
--- a/dev-vcs/rsvndump/rsvndump-0.6-r1.ebuild
+++ b/dev-vcs/rsvndump/rsvndump-0.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,6 +29,18 @@ PATCHES=(
src_prepare() {
default
+
+ # We need to patch use of /usr/lib because it is a problem with
+ # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/739028).
+ # The grep sandwich acts as a regression test so that a future
+ # version bump cannot break patching without noticing.
+ grep -wq svn_prefix/lib m4/find_svn.m4 || die
+ sed "s,svn_prefix/lib,svn_prefix/$(get_libdir)," -i m4/find_svn.m4 || die
+ grep -w svn_prefix/lib m4/find_svn.m4 && die
+ grep -wq SVN_PREFIX/lib configure.ac || die
+ sed "s,SVN_PREFIX/lib,SVN_PREFIX/$(get_libdir)," -i configure.ac || die
+ grep -w SVN_PREFIX/lib configure.ac && die
+
eautoreconf
}
diff --git a/dev-vcs/rsvndump/rsvndump-0.6.ebuild b/dev-vcs/rsvndump/rsvndump-0.6.ebuild
deleted file mode 100644
index 0fd269ce1768..000000000000
--- a/dev-vcs/rsvndump/rsvndump-0.6.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Dump a remote Subversion repository"
-HOMEPAGE="http://rsvndump.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3+ BSD public-domain" # rsvndump, snappy-c, critbit89
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc"
-
-RDEPEND="dev-vcs/subversion
- dev-libs/apr
- dev-libs/apr-util
- sys-devel/gettext"
-DEPEND="${RDEPEND}
- doc? ( app-text/xmlto
- >=app-text/asciidoc-8.4 )"
-
-src_configure() {
- econf \
- $(use_enable doc man) \
- $(use_enable debug)
-}