summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-16 16:13:47 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-16 16:20:54 +0200
commit97fe9d5daa9eef81559bf67833a41b2e1257ac18 (patch)
tree2e7dc929eabc1c8fdcf1242abd1f4e67e8d7d24f /dev-vcs/tig/tig-2.1.1.ebuild
parentnet-analyzer/iftop: Use slot operators for ncurses (diff)
downloadgentoo-97fe9d5daa9eef81559bf67833a41b2e1257ac18.tar.gz
gentoo-97fe9d5daa9eef81559bf67833a41b2e1257ac18.tar.bz2
gentoo-97fe9d5daa9eef81559bf67833a41b2e1257ac18.zip
dev-vcs/tig: Use slot operators for ncurses; Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-vcs/tig/tig-2.1.1.ebuild')
-rw-r--r--dev-vcs/tig/tig-2.1.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-vcs/tig/tig-2.1.1.ebuild b/dev-vcs/tig/tig-2.1.1.ebuild
new file mode 100644
index 000000000000..3a943bbc1f82
--- /dev/null
+++ b/dev-vcs/tig/tig-2.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="unicode"
+
+DEPEND="
+ sys-libs/ncurses:5=[unicode?]
+ sys-libs/readline:0"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+src_prepare() {
+ # pre-generated manpages are in the root directory
+ sed -i '/^MANDOC/s#doc/##g' Makefile || die
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_test() {
+ # workaround parallel test failures
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dohtml manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+
+ docinto examples
+ dodoc contrib/*.tigrc
+}