summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-09-01 17:48:29 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-09-04 09:20:48 +0300
commita8faa501f53b60b8b8008e0e34b93b4862dd8bd9 (patch)
treec4fced88e3a88c180f537577e8b8737375cb60af /dev-vcs/tortoisehg
parentnet-misc/asterisk: version 16.20.0 (diff)
downloadgentoo-a8faa501f53b60b8b8008e0e34b93b4862dd8bd9.tar.gz
gentoo-a8faa501f53b60b8b8008e0e34b93b4862dd8bd9.tar.bz2
gentoo-a8faa501f53b60b8b8008e0e34b93b4862dd8bd9.zip
dev-vcs/tortoisehg: 5.9 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs/tortoisehg')
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-5.9.ebuild80
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild6
3 files changed, 84 insertions, 3 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 275f6c34b562..80c63b66f407 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -1,2 +1,3 @@
DIST tortoisehg-5.8.tar.gz 8636455 BLAKE2B 1f4171ca4eb465aabacaf53b97785c5f05fc501a11329af008695f706d8d2cb9c5eee5e64bb5a60fdf7234f33ed6a937dfacce49cb36ac9e9b8505be271b4f35 SHA512 b9fe80a98cfafe0dbc90be5fe6f83b466fe596b4ec135d0eacc5618e39c0249a3a352bed640a7cecb99d53eaf60908d60d7748009492cbd8202fc191ef428278
DIST tortoisehg-5.8.1.tar.gz 8636858 BLAKE2B 66473695e1364ff676ab314ce8b5a5e59cbe6ece68795d92278e450f70386a9e047dfd8975e7312bda10c183879d9634767f64a9c916f889f3edcf4847bf2468 SHA512 29903240c5522841e0ddc0f78741d20d589b6b48e82bf38023b87184e987721111a6a9675ccb85a31d9781cf1b8fa3d28801fef5bae187ae467d7da8f1ef982f
+DIST tortoisehg-5.9.tar.gz 8637690 BLAKE2B 818b866314a04857838ea971d9a26df6604fc97a7968ee1419337fccc413d228e5597bef80256b35a2084956f356e9015c2c9c00181ab600ee75b5a86f8ec358 SHA512 14b91a2193f0eaeb39d49b131ec9214732b6898e7ee2a57091cf5be61a37ec5a0b71d8eea5d67b30ea8796565c25aa1bd1fd23ff178ae1a7dcdbfd5b333e525f
diff --git a/dev-vcs/tortoisehg/tortoisehg-5.9.ebuild b/dev-vcs/tortoisehg/tortoisehg-5.9.ebuild
new file mode 100644
index 000000000000..a68201d3b429
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-5.9.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit desktop distutils-r1 optfeature xdg-utils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${PV}/thg-${PV}.tar.gz -> ${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-5.8[${PYTHON_USEDEP}]
+ <dev-vcs/mercurial-5.10[${PYTHON_USEDEP}]"
+ S="${WORKDIR}/thg-${PV}"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://foss.heptapod.net/mercurial/${PN}/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND=">=dev-vcs/mercurial-5.8[${PYTHON_USEDEP}]"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.9.4[qt5(+),${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/mock
+ dev-python/pytest
+ )
+"
+
+distutils_enable_sphinx doc/source
+
+python_prepare_all() {
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
+
+ sed -i -e 's:share/doc/tortoisehg:share/doc/'"${PF}"':' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} tests/run-tests.py -m 'not largefiles' --doctest-modules tests || die
+ ${EPYTHON} tests/run-tests.py -m largefiles tests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+ elog "dev-python/qscintilla-python."
+
+ optfeature "the core git extension support" dev-python/pygit2
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 702819ea4b0b..a68201d3b429 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -11,14 +11,14 @@ inherit desktop distutils-r1 optfeature xdg-utils
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~arm64 ~x86"
SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${PV}/thg-${PV}.tar.gz -> ${P}.tar.gz"
- HG_DEPEND=">=dev-vcs/mercurial-5.7[${PYTHON_USEDEP}]
- <dev-vcs/mercurial-5.9[${PYTHON_USEDEP}]"
+ HG_DEPEND=">=dev-vcs/mercurial-5.8[${PYTHON_USEDEP}]
+ <dev-vcs/mercurial-5.10[${PYTHON_USEDEP}]"
S="${WORKDIR}/thg-${PV}"
else
inherit mercurial
EHG_REPO_URI="https://foss.heptapod.net/mercurial/${PN}/thg"
EHG_REVISION="stable"
- HG_DEPEND=">=dev-vcs/mercurial-5.7[${PYTHON_USEDEP}]"
+ HG_DEPEND=">=dev-vcs/mercurial-5.8[${PYTHON_USEDEP}]"
fi
DESCRIPTION="Set of graphical tools for Mercurial"