summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-02-25 16:18:31 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-02-25 16:42:03 -0600
commitc412040bd725e5ab47c49e8b255310d10f6a46ca (patch)
treeb1af949f2839387491de42921507848f4fe8ea08 /dev-vcs/vcsh/vcsh-1.20151229.1.ebuild
parentsci-biology/prodigal: Remove old (diff)
downloadgentoo-c412040bd725e5ab47c49e8b255310d10f6a46ca.tar.gz
gentoo-c412040bd725e5ab47c49e8b255310d10f6a46ca.tar.bz2
gentoo-c412040bd725e5ab47c49e8b255310d10f6a46ca.zip
dev-vcs/vcsh: version bump to 1.20151229.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-vcs/vcsh/vcsh-1.20151229.1.ebuild')
-rw-r--r--dev-vcs/vcsh/vcsh-1.20151229.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-vcs/vcsh/vcsh-1.20151229.1.ebuild b/dev-vcs/vcsh/vcsh-1.20151229.1.ebuild
new file mode 100644
index 000000000000..2a0c55a4ba57
--- /dev/null
+++ b/dev-vcs/vcsh/vcsh-1.20151229.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit versionator
+
+DESCRIPTION='Manage config files in $HOME via fake bare git repositories'
+HOMEPAGE="https://github.com/RichiH/vcsh/"
+
+MY_PV="$(replace_version_separator 2 '-')"
+SRC_URI="https://github.com/RichiH/vcsh/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+RDEPEND="dev-vcs/git"
+DEPEND=""
+
+DOCS=( changelog README.md CONTRIBUTORS )
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's,vendor-completions,site-functions,' \
+ -e "s,\(\$(DOCDIR_PREFIX)\)/\$(self),\1/${PF}," \
+ Makefile || die "sed failed"
+
+ # remove dysfunctional tests
+ sed -i -e 's,install: all,install:,' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ default
+ dodoc -r doc/sample_hooks
+}