summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-02-27 23:11:32 -0600
committerMatthias Maier <tamiko@gentoo.org>2016-02-27 23:11:32 -0600
commit44b677a2e0a9979ece299672c0f3bf2c822bc087 (patch)
tree3f8c1363e41e86b51aa259530cf2dcbd9ad77304 /dev-vcs/vcsh/vcsh-1.20151229.ebuild
parentdev-vcs/vcsh: drop old 1.20140508-r2, 1.20141026 (diff)
downloadgentoo-44b677a2e0a9979ece299672c0f3bf2c822bc087.tar.gz
gentoo-44b677a2e0a9979ece299672c0f3bf2c822bc087.tar.bz2
gentoo-44b677a2e0a9979ece299672c0f3bf2c822bc087.zip
dev-vcs/vcsh: version bump to 1.20151229
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-vcs/vcsh/vcsh-1.20151229.ebuild')
-rw-r--r--dev-vcs/vcsh/vcsh-1.20151229.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-vcs/vcsh/vcsh-1.20151229.ebuild b/dev-vcs/vcsh/vcsh-1.20151229.ebuild
new file mode 100644
index 000000000000..8bbd84553165
--- /dev/null
+++ b/dev-vcs/vcsh/vcsh-1.20151229.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION='Manage config files in $HOME via fake bare git repositories'
+HOMEPAGE="https://github.com/RichiH/vcsh/"
+SRC_URI="https://github.com/RichiH/vcsh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+DEPEND=""
+
+DOCS=( changelog README.md CONTRIBUTORS )
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's,vendor-completions,site-functions,' \
+ -e "s,\(\$(DOCDIR_PREFIX)\)/\$(self),\1/${PF}," \
+ Makefile || die "sed failed"
+
+ # remove dysfunctional tests
+ sed -i -e 's,install: all,install:,' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ default
+ dodoc -r doc/sample_hooks
+}