summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-09-09 11:46:20 +0100
committerMarek Szuba <marecki@gentoo.org>2021-09-09 12:20:17 +0100
commit26a0bece0dcad9bf9a80919c143ea4e18a537185 (patch)
tree01db86ccc447cf2a68f51e27287deab688a41723 /dev-vcs
parentdev-python/unidecode: fix setuptools dependency (diff)
downloadgentoo-26a0bece0dcad9bf9a80919c143ea4e18a537185.tar.gz
gentoo-26a0bece0dcad9bf9a80919c143ea4e18a537185.tar.bz2
gentoo-26a0bece0dcad9bf9a80919c143ea4e18a537185.zip
dev-vcs/pre-commit: add 2.15.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.15.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 3afd8a4ec953..c714de0e5c04 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1 +1,2 @@
DIST pre-commit-2.13.0.tar.gz 252631 BLAKE2B 7e6b3af46dfaf9928d2cb2aa6cad05423bf6e417e2324af71b241e1aaa2eec6fcb271869f98c040cd4fb8c608a1fabd244c8286864f469a06c44684cd2bf33eb SHA512 5dfc297b3f900afef8f1c355b38ce086af7c836d1e577af8ec95ffb30e82df8b866131da4ff12933339bda63e4a90833c3852265d4f2d4a59bf92bce2b972a5e
+DIST pre-commit-2.15.0.tar.gz 255545 BLAKE2B 8fbb1fd6b1298ff1c5a6884dae53c79d108e8c4b74d05d6be36d562327fd024432d60e6df4570217e1b3f4ad8e33ee4d0d54a5d940f4833a46d4e9cb59698b3c SHA512 b87985aa625509d7a21e31e5774f259c264ec74fef88fc5e290cbac0326cdbadc37ab54b5bf3048d815cf9bc6d4adb71619fcb84c955c1bc9741da8dfd34251c
diff --git a/dev-vcs/pre-commit/pre-commit-2.15.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.15.0.ebuild
new file mode 100644
index 000000000000..f557aafa2ebc
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-2.15.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+# TODO: figure out why these tests - all of which invoke git - fail:
+# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall],
+# tests/main_test.py::test_try_repo:
+# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+# NOT a sandbox issue it seems, as disabling it does not help.
+# - tests/commands/install_uninstall_test.py::test_environment_not_sourced:
+# Unexpected error "/usr/bin/env: 'python3.8': No such file or directory" - but only if pre-commit
+# has previously been installed.
+# - tests/commands/install_uninstall_test.py::test_installed_from_venv:
+# the function invoking "git commit" returns 1 instead of 0, no details.
+RESTRICT="test"
+
+RDEPEND="dev-vcs/git
+ $(python_gen_cond_dep '
+ dev-python/cfgv[${PYTHON_USEDEP}]
+ dev-python/identify[${PYTHON_USEDEP}]
+ dev-python/nodeenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+)"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ default
+
+ # These tests require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+ # and while some of them do include "skip if not found" logic, most of them do not.
+ rm -rf tests/languages tests/repository_test.py
+}