summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-05-15 16:47:37 +0800
committerYixun Lan <dlan@gentoo.org>2021-05-15 17:01:27 +0800
commit26ba59522e1d1d218c85df3c9b8d2a49b0de5ef8 (patch)
tree6d28ac3154d9d65cf68836f5665ceedaeb765897 /dev-vcs
parentdev-util/crash: version bump, 7.3.0 (diff)
downloadgentoo-26ba59522e1d1d218c85df3c9b8d2a49b0de5ef8.tar.gz
gentoo-26ba59522e1d1d218c85df3c9b8d2a49b0de5ef8.tar.bz2
gentoo-26ba59522e1d1d218c85df3c9b8d2a49b0de5ef8.zip
dev-vcs/stgit: version bump, 1.1
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/stgit/Manifest1
-rw-r--r--dev-vcs/stgit/metadata.xml4
-rw-r--r--dev-vcs/stgit/stgit-1.1.ebuild80
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
index bc254158f143..e1fbe6792269 100644
--- a/dev-vcs/stgit/Manifest
+++ b/dev-vcs/stgit/Manifest
@@ -1,2 +1,3 @@
DIST stgit-0.23.tar.gz 303836 BLAKE2B 018e0caf74a3c449a71362e3694b2ddf030f5ee23e3212a98b378b7118bae9fd15d0e4ab2a2a746a12b34e46aa2edb86657a4a7125f3c5ca8aa0142fe3d73534 SHA512 b3c9b5c0833cb7e5137faf0df48af6a11b9508b994cdf55b587567d1c146fd4ae29e7beb6d1a34b3f87e5b3854af035dd7e5ca35338c20740e91da7b47c4568d
DIST stgit-1.0.tar.gz 302201 BLAKE2B 2be1eb648edbefed6270e8f52039afd5d6d4140e8e16656a9f28f6b168eb5ce02c814a3e2b91bc628a80de1e15f0491b82af18fc2cad4e556bcd23ef247fe082 SHA512 e33db953d810f024ee2159ea5bb1b1367a5c673d78d789e8b20ad1d773dccaaf0fe4ccb713b8de082d4a79a3f51d421a2d3d88be24f2e0e770e070e640744894
+DIST stgit-1.1.tar.gz 313862 BLAKE2B 2d15ba7c2f55ff1211f0d9a3002878102f5023e897d0830daa688a2af8c6a386ec0cf076c728b6f45650ee3382379a32fb4efb25d0da3b28302f158dfca6ef62 SHA512 917c645f219b2725d1e88186674a6184c96f1457d5c7722b4da17931d963f0fe0c675cdaaca435ba7405ba498d6db9a01c9f554d1aa3093cc3205d224d9d9759
diff --git a/dev-vcs/stgit/metadata.xml b/dev-vcs/stgit/metadata.xml
index 4f503c94254e..43dd4526edf3 100644
--- a/dev-vcs/stgit/metadata.xml
+++ b/dev-vcs/stgit/metadata.xml
@@ -5,4 +5,8 @@
<email>dlan@gentoo.org</email>
<name>Yixun Lan</name>
</maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">stacked-git/stgit</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-vcs/stgit/stgit-1.1.ebuild b/dev-vcs/stgit/stgit-1.1.ebuild
new file mode 100644
index 000000000000..e44a2c6fd258
--- /dev/null
+++ b/dev-vcs/stgit/stgit-1.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="https://stacked-git.github.io"
+UPSTREAM_VER=
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+pkg_setup() {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+python_prepare_all() {
+ # Upstream's patchset
+ [[ -n ${UPSTREAM_VER} ]] && \
+ eapply "${WORKDIR}"/patches-upstream
+
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ echo "version=\"${PV}\"" > "${S}"/stgit/builtin_version.py
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ # bug 526468
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ doc
+ fi
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ install-doc install-html
+ fi
+
+ distutils-r1_src_install
+
+ newbashcomp completion/stgit.bash 'stg'
+}