summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-04-15 17:31:54 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-04-15 17:32:48 -0500
commit2e587621837c6f0561b89306b3b0f0fe8d13185a (patch)
tree34b1ad8467faf0be3a6eef9248c3228753dafe64 /dev-vcs
parentdev-python/tld: 0.9.3 bump (diff)
downloadgentoo-2e587621837c6f0561b89306b3b0f0fe8d13185a.tar.gz
gentoo-2e587621837c6f0561b89306b3b0f0fe8d13185a.tar.bz2
gentoo-2e587621837c6f0561b89306b3b0f0fe8d13185a.zip
dev-vcs/python-gitlab: 1.8 bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.8.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index e05c6e1a3b68..deb192a11aeb 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -1 +1,2 @@
DIST python-gitlab-1.7.0.tar.gz 110657 BLAKE2B 1003d3373d3ef5474b1d5c10b1c6af57e7467cec432fc1eb75b4e1ba7766361641f25461ac2bf1b7692dab855d4e5cbc204240ede3568e71ed1af75682807fb0 SHA512 ad50d989e27948ff5188f4191ad3b7f1e1b45608627b2042bf02d635b2aa8da0a24f6b0383f483a01df54e4ab14576e7e4252576b9c2bdf67a187ae6aad69d53
+DIST python-gitlab-1.8.0.tar.gz 115603 BLAKE2B 8ebebc1735e5531b4f95d82122b6ecf78fd541bce503f0cdf8c47b2ec2edab89efcad6c0ab39d82b57ffb8c3e341cb2160916b7df6c4886465e90557db3141c3 SHA512 4843aefb7cd363520e9065cfc08b81ec2c5c2c9cbdb5d6adbd35ec0f615bafd40e66746739c910b5e7e041f06e2aa9dc8beb8a884a714e6837cd5fb6fefb53be
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.8.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.8.0.ebuild
new file mode 100644
index 000000000000..2ee27c73fd03
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-1.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testrepository[${PYTHON_USEDEP}]
+ dev-python/hacking[${PYTHON_USEDEP}]
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3
+ dev-python/sphinx_rtd_theme )"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}