summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2016-10-03 09:49:09 +0100
committerMike Auty <ikelos@gentoo.org>2016-10-03 09:49:09 +0100
commit547bf1f772e2900745767349468e13960d84f8d5 (patch)
tree1b7773bc0384472c2e7a832889e0ceb2bf24666e /dev-vcs
parentsys-apps/grep: Removed old. (diff)
downloadgentoo-547bf1f772e2900745767349468e13960d84f8d5.tar.gz
gentoo-547bf1f772e2900745767349468e13960d84f8d5.tar.bz2
gentoo-547bf1f772e2900745767349468e13960d84f8d5.zip
dev-vcs/giggle: Move to vte-2.91 (bug #595902).
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/giggle/files/giggle-0.7-vte-2.91.patch57
-rw-r--r--dev-vcs/giggle/giggle-0.7-r2.ebuild47
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-vcs/giggle/files/giggle-0.7-vte-2.91.patch b/dev-vcs/giggle/files/giggle-0.7-vte-2.91.patch
new file mode 100644
index 000000000000..f800a9d157ca
--- /dev/null
+++ b/dev-vcs/giggle/files/giggle-0.7-vte-2.91.patch
@@ -0,0 +1,57 @@
+From b9e260840d03e33ac55142719f3d54129b54cc70 Mon Sep 17 00:00:00 2001
+From: Debarshi Ray <debarshir@gnome.org>
+Date: Mon, 26 Jan 2015 15:38:24 +0100
+Subject: [PATCH] Port to vte-2.91 API
+
+https://bugzilla.gnome.org/show_bug.cgi?id=743537
+---
+ configure.ac | 2 +-
+ plugins/giggle-view-terminal.c | 19 ++++++++++---------
+ 2 files changed, 11 insertions(+), 10 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6e27733..72e7bd1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -106,7 +106,7 @@ AC_ARG_ENABLE([terminal],
+ AS_IF([test "x$enable_terminal" = "xyes"],
+ [
+ PKG_CHECK_MODULES([VTE],
+- [vte-2.90 >= $VTE_REQUIRED_VERSION],
++ [vte-2.91 >= $VTE_REQUIRED_VERSION],
+ [have_vte=yes
+ AC_DEFINE([HAVE_VTE], [1],
+ [Use features from vte])
+diff --git a/plugins/giggle-view-terminal.c b/plugins/giggle-view-terminal.c
+index 06a9a50..cd107f2 100644
+--- a/plugins/giggle-view-terminal.c
++++ b/plugins/giggle-view-terminal.c
+@@ -186,15 +186,16 @@ giggle_view_terminal_append_tab (GiggleViewTerminal *view,
+ real_argv[1] = NULL;
+ spawn_flags = G_SPAWN_CHILD_INHERITS_STDIN | G_SPAWN_SEARCH_PATH | G_SPAWN_FILE_AND_ARGV_ZERO;
+
+- succes = vte_terminal_fork_command_full (VTE_TERMINAL (terminal),
+- pty_flags,
+- directory,
+- real_argv,
+- NULL,
+- spawn_flags,
+- NULL, NULL,
+- NULL,
+- &error);
++ succes = vte_terminal_spawn_sync (VTE_TERMINAL (terminal),
++ pty_flags,
++ directory,
++ real_argv,
++ NULL,
++ spawn_flags,
++ NULL, NULL,
++ NULL,
++ NULL,
++ &error);
+ g_strfreev (real_argv);
+
+ if (succes == FALSE) {
+--
+2.1.0
+
diff --git a/dev-vcs/giggle/giggle-0.7-r2.ebuild b/dev-vcs/giggle/giggle-0.7-r2.ebuild
new file mode 100644
index 000000000000..0a0bb5485069
--- /dev/null
+++ b/dev-vcs/giggle/giggle-0.7-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 eutils
+
+DESCRIPTION="GTK+ Frontend for GIT"
+HOMEPAGE="https://wiki.gnome.org/Apps/giggle"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="eds"
+
+RDEPEND="
+ >=dev-vcs/git-1.5
+ >=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.3.12:3
+ >=x11-libs/gtksourceview-3.0:3.0
+ >=x11-libs/gdk-pixbuf-2.22.0
+ eds? ( gnome-extra/evolution-data-server )
+ >=x11-libs/vte-0.28:2.91
+"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ sys-devel/gettext
+ app-text/yelp-tools
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35
+ >=sys-devel/autoconf-2.64
+ >=sys-devel/libtool-2
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.6.2-gtksourceview-3.8.0.patch"
+ epatch "${FILESDIR}/${PN}-0.7-vte-2.91.patch"
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable eds evolution-data-server)
+}