summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-06-05 10:51:24 +0200
committerJohannes Huber <johu@gentoo.org>2017-06-05 10:51:45 +0200
commit6fcd22e6f3d83e9d4c75284cb348047783b180c5 (patch)
treec02d22435778e4657e45de51322d65d49f6dd366 /dev-vcs
parentdev-ruby/yajl-ruby: add ruby24 (diff)
downloadgentoo-6fcd22e6f3d83e9d4c75284cb348047783b180c5.tar.gz
gentoo-6fcd22e6f3d83e9d4c75284cb348047783b180c5.tar.bz2
gentoo-6fcd22e6f3d83e9d4c75284cb348047783b180c5.zip
dev-vcs/git-flow: Version bump 1.11.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-flow/Manifest2
-rw-r--r--dev-vcs/git-flow/git-flow-1.11.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/git-flow/Manifest b/dev-vcs/git-flow/Manifest
index 7134c0469769..495a43bcc2f0 100644
--- a/dev-vcs/git-flow/Manifest
+++ b/dev-vcs/git-flow/Manifest
@@ -1,2 +1,4 @@
DIST git-flow-1.10.2.tar.gz 63275 SHA256 09b9de0790276cbff2906c31193bdac859235a0cdfb56cedd13b4a1a4ee75065 SHA512 139e56eb872a3db271a0e7c65c8d55d2720c06646c2569f14d8e7485d3888918fa8390a95a9df48b4677c1a225367b5aeadf4e7705b9475c38f9e931ea45fe03 WHIRLPOOL 1cb551e9f3f71a5e7b205b57d4c216f3b9bc7afe622de6b6944183baeffdf3fdb59d6e0dd06afe5e06dc3c3c0d0bebf5aa08ce8a5151e1413b01ceec671a2552
+DIST git-flow-1.11.0.tar.gz 64077 SHA256 06ad2110088e46e3712f799a43bf6cc5c3720fc25c69dbb3bbf4cf486cf2f330 SHA512 3659f876febbec10457ba7ba1ecbaeb7f29b11cc8caf94042f54b8f8e2265d2bb31cbcdf7dfafae9c5d04e0ca57adddfa67f9e67df4a5dcf0bc412f1216a3c07 WHIRLPOOL dc9eae1513901596b1f657ac0af58bd7fed0f3d7aa426654214c87676a636d19555841b95754d633605b0cdeaa43cfac13431e522760cd159675de6a8b7489ed
DIST git-flow-completion-0.5.2.tar.gz 7501 SHA256 7d11d82b9a3c25f7c7189ac61d21a4edb2432435d6138f092f49348bb17917df SHA512 500cb6163ebb2bf9b996dd5bcac00efa857badfc95ee1d633f2b16803c6baae7315a96c713107645e0971be4736fe1eef747dc773eb50da138551be4838c21b3 WHIRLPOOL 90eaf0d6adcc87369455129052cbcad9c153fe91892a0607fd311bb370a1004b9f85664d0fb06907369bc6bbe6a224a95981fa5d5518610fab2cade0d33c7957
+DIST git-flow-completion-0.6.0.tar.gz 7823 SHA256 b1b78b785aa2c06f81cc29fcf03a7dfc451ad482de67ca0d89cdb0f941f5594b SHA512 1082ad47938ec78045f4cbd12340a82960ba3de204c21a95e1166cb0b86e96dbbc3e5fc8af1945c951d5edd43b4026021761e8377795acbb87af3c1e391cb256 WHIRLPOOL ac5189b75e6ca5a5136d1d6f3ee5e866696c87d810406b79b2e3d444cc7c4d8e9222c9057e7bea024b0e754ba419edb908173cf3d1af6c940af792d7eb0d06b9
diff --git a/dev-vcs/git-flow/git-flow-1.11.0.ebuild b/dev-vcs/git-flow/git-flow-1.11.0.ebuild
new file mode 100644
index 000000000000..a90de66ee5e3
--- /dev/null
+++ b/dev-vcs/git-flow/git-flow-1.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-/}-avh"
+COMP_PN="${PN}-completion"
+COMP_PV="0.6.0"
+COMP_P="${COMP_PN}-${COMP_PV}"
+inherit bash-completion-r1
+
+DESCRIPTION="Git extensions to provide high-level repository operations"
+HOMEPAGE="https://github.com/petervanderdoes/gitflow-avh"
+SRC_URI="https://github.com/petervanderdoes/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/petervanderdoes/${COMP_PN}/archive/${COMP_PV}.tar.gz -> ${COMP_P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+DOCS=( AUTHORS CHANGELOG.md README.md )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_compile() {
+ true
+}
+
+src_install() {
+ emake prefix="${D}/usr" install
+ einstalldocs
+ newbashcomp "${WORKDIR}/${COMP_P}/${COMP_PN}.bash" ${PN}
+}