summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-09-14 01:21:43 +0200
committerChristoph Junghans <ottxor@gentoo.org>2016-09-14 09:16:21 -0600
commit7ccfe1f9f9c79ffbd38b9aa91f072eaab190693f (patch)
treed6000d47523d819ae31a43d07640dca9ad5ef3af /dev-vcs
parentapp-office/geierlein: version bump to 0.9.5 (diff)
downloadgentoo-7ccfe1f9f9c79ffbd38b9aa91f072eaab190693f.tar.gz
gentoo-7ccfe1f9f9c79ffbd38b9aa91f072eaab190693f.tar.bz2
gentoo-7ccfe1f9f9c79ffbd38b9aa91f072eaab190693f.zip
dev-vcs/hg-fast-export: bump to 20160914, add ~x86
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hg-fast-export/Manifest1
-rw-r--r--dev-vcs/hg-fast-export/hg-fast-export-20160914.ebuild41
-rw-r--r--dev-vcs/hg-fast-export/metadata.xml1
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-vcs/hg-fast-export/Manifest b/dev-vcs/hg-fast-export/Manifest
index 19cb245685cb..2ef08d524443 100644
--- a/dev-vcs/hg-fast-export/Manifest
+++ b/dev-vcs/hg-fast-export/Manifest
@@ -1,3 +1,4 @@
DIST hg-fast-export-20140328.tar.gz 14436 SHA256 a580dcd0ab2205de8e59cd3c46a23661799e433293b5a8d52179632eead0a690 SHA512 9eb7613634a176a5f273f5f86d0cdc544b360e98743866e47cf36859e1a84e95bb88b646e7c36d8671b7c7e61a0601684c38372c95aa173d324b897d6db7a39c WHIRLPOOL 1dd863a7685713fe244d71af1d7ffcbcb45a0904fad0cd31be64b524c7e5d37bd51ad13c11205eb587e606b57148f86041f334423d808335bf3137c46be9ce31
DIST hg-fast-export-20140706.tar.gz 14671 SHA256 cab19797e7903fc7c6aeee00317d27608d1724837554c2dea47ac531b348cd73 SHA512 1c7421f6944af822dd0a6b8ac23c31f198b15da77a16773c5fd80371c3e059e1f45c1e67e5d88cfcf130e648252a76d923badf7fa2e0e3bd1a32e561c1c8f150 WHIRLPOOL 43d96daf9a77b18c7e7e2fe5375107a00e2b92f4ee1ed303534dfff42077b0a27c52ab65b89f308e3f5bda23f58a4f073537c60c69e94fed7f191e22bb04a49c
DIST hg-fast-export-20150816.tar.gz 15245 SHA256 d1c31db38318ce8af1abcdc75a02ee9f738ff652f602309ce4ded884ad8d1406 SHA512 d6276c4f2eaaf580d2218f8561e9e60191dfcecdfbc612e0d216475fd16d1257c65ea95415cdd9a57a1c7f18773d616fad610a7931747e6579d6529e40a84a8a WHIRLPOOL fb6106fec5e33e26843d1967ce6f9eacb570906b5e77b62732820f85cc54eadcbd218a3e53c7fef00d9621865b0c976537e02c9f4c13a25fca53c57cf975d026
+DIST hg-fast-export-20160914.tar.gz 11379 SHA256 1eb2c520f9fa93413d17e4a4551e3dde0dad31564498f1204b191741bd5a4763 SHA512 9e57e7835cc50e8db5d2ebf840d60b4ce25ec19e9722e705eba1178cc41fde57129664de3e1fc157ce8352632c8d0b8be33109afa50b53e159793a8a2ed21fea WHIRLPOOL 53daa9e7ab09f39b76b3eea28fcf8be080a2841cbba146626aabc147c8f3343de06e9f1c9a9aae34f90a4d86eb138f234fe71bd554c723a70a3cb8cb1f0d40df
diff --git a/dev-vcs/hg-fast-export/hg-fast-export-20160914.ebuild b/dev-vcs/hg-fast-export/hg-fast-export-20160914.ebuild
new file mode 100644
index 000000000000..91fdee4acab4
--- /dev/null
+++ b/dev-vcs/hg-fast-export/hg-fast-export-20160914.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 vcs-snapshot
+
+COMMIT="v${PV#20}"
+DESCRIPTION="mercurial to git converter using git-fast-import"
+HOMEPAGE="https://github.com/frej/fast-export"
+SRC_URI="${HOMEPAGE}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+ sed -e '/^PYTHON/s/python/&2.7/' \
+ -e '/^PYTHON/s/PYTHON:/E&/g' \
+ -e "/^ROOT/s:=.*:='${EPREFIX}/usr/bin':" \
+ -i "${PN}".sh hg-reset.sh || die
+}
+
+src_install() {
+ default
+ newbin "${PN}".sh "${PN}"
+ newbin hg-reset.sh hg-reset
+ python_foreach_impl python_doexe "${PN}".py
+ python_foreach_impl python_doexe hg-reset.py
+ python_foreach_impl python_domodule hg2git.py
+}
diff --git a/dev-vcs/hg-fast-export/metadata.xml b/dev-vcs/hg-fast-export/metadata.xml
index 24aedeadb2be..c6493cdd4cac 100644
--- a/dev-vcs/hg-fast-export/metadata.xml
+++ b/dev-vcs/hg-fast-export/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="github">frej/fast-export</remote-id>
+ <bugs-to>https://github.com/frej/fast-export/issues</bugs-to>
</upstream>
</pkgmetadata>