summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-06-18 17:09:12 -0400
committerBrian Evans <grknight@gentoo.org>2017-06-18 17:09:12 -0400
commit875a97f9223c356ac53da70be705a8e11a1de613 (patch)
treecafc0fc2154fc7b0df2f8963bc31c4f89990ad9e /dev-vcs
parentapp-misc/pwsafe: delete old unstable version. (diff)
downloadgentoo-875a97f9223c356ac53da70be705a8e11a1de613.tar.gz
gentoo-875a97f9223c356ac53da70be705a8e11a1de613.tar.bz2
gentoo-875a97f9223c356ac53da70be705a8e11a1de613.zip
dev-vcs/git-cola: Version bump to 2.11 wrt bug 601786
Non-Maintainer commit, maintainer unresponsive for several months. This version adds python 3.5 and PyQt5 as the primary GUI One encoding test fails, but it seems to be minor. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/Manifest1
-rw-r--r--dev-vcs/git-cola/files/git-cola-2.10-disable-live-tests.patch24
-rw-r--r--dev-vcs/git-cola/git-cola-2.11.ebuild104
3 files changed, 129 insertions, 0 deletions
diff --git a/dev-vcs/git-cola/Manifest b/dev-vcs/git-cola/Manifest
index c27708f6d402..60279e634706 100644
--- a/dev-vcs/git-cola/Manifest
+++ b/dev-vcs/git-cola/Manifest
@@ -1,3 +1,4 @@
+DIST git-cola-2.11.tar.gz 1179769 SHA256 bc4007e0d9c80763ef58d630b033bfdbd8406af77bbd292a6c647ed3ca655b5b SHA512 99b865d7a49dcb041e54811141d242386642b5ed6fc12fa7a03431eb9b905cb88d88c4892dc432dd59e8ae3c85f20cc40f4bfb9b6ff002f4e5a4cfc0bdc4c72c WHIRLPOOL e7a3a1d50b6730aefd48e2d0a91cb3bf413240c516194ae39a2b6a7ebb5b07807bba10f51e1c3669817eed49aa938b01328416ca60cfcc684f95bbcd0005eaa2
DIST git-cola-2.2.1.tar.gz 996484 SHA256 df0a3e1d3c49629926f2e30f55d635eca3c8da12e96232196b307613fa4b3aec SHA512 a91fe706ea150d9bd9a05a9d494c63d373cae0154deca8e40e30fc20e70be32d4fd1f021a971c067d46ab24f472965a12c115eeb4bd94e4f62c21e546d89c109 WHIRLPOOL ac68a558775bc5fdf3a168416132dedbeffe554f6f60f50b7e33f0d17d67aa829318b7a0df2607b47e41b8823d60e206e0544e03382eae7651b9ca1c3b9dfc09
DIST git-cola-2.3.tar.gz 1005858 SHA256 3319810c16f6864deb5f94f533c7cfd17f30961595454da7c3c75879f56511b3 SHA512 2be0e971cd23aa0a1f8ec92ffd05f64cdd0ee34fb1e3c9bd3a98df0556968e9613d6494002e973db8de8ab389c48205ab1db42823d46e523c24a029cf25e3023 WHIRLPOOL 177996e40cc83dd2d2fe9db1ac97ba318d9d311779415e8e4327f3824a7c19f36f592ed1d6118e5a2d46a594a8dd681d0a2e2e54f2846c3636d9f4f3d8f196f5
DIST git-cola-2.4.tar.gz 987829 SHA256 ef735431a2e58bac7671c4b9ab4fbb369195b16987fe9d3d931a9097c06c7f36 SHA512 702d5c7322a21e5807354d3b3b7b31fd5cef3c12c3294e2ad57add99f586277d4805e85122682acde40e6243529588e62762f9483d807ed12340057c6a37a0cc WHIRLPOOL de95800c0d8f67d301a102a8f623945170ca5961cde91fdabf2dd396f2470e52e8b51dde1f65b5aed408ebc3cd6802426c7bd3b9cd86db53b2965067d2646f47
diff --git a/dev-vcs/git-cola/files/git-cola-2.10-disable-live-tests.patch b/dev-vcs/git-cola/files/git-cola-2.10-disable-live-tests.patch
new file mode 100644
index 000000000000..1f58ea0eddb6
--- /dev/null
+++ b/dev-vcs/git-cola/files/git-cola-2.10-disable-live-tests.patch
@@ -0,0 +1,24 @@
+diff --git a/test/git_test.py b/test/git_test.py
+index 9f812b2..ff7da24 100644
+--- a/test/git_test.py
++++ b/test/git_test.py
+@@ -53,19 +53,6 @@ class GitCommandTest(unittest.TestCase):
+ version = self.git.version()[STDOUT]
+ self.failUnless(version.startswith('git version'))
+
+- def test_tag(self):
+- """Test running 'git tag'"""
+- tags = self.git.tag()[STDOUT].splitlines()
+- if os.getenv('GIT_COLA_NO_HISTORY', False):
+- return
+- self.failUnless('v1.0.0' in tags)
+-
+- def test_show(self):
+- """Test running 'git show'"""
+- oid = 'HEAD'
+- content = self.git.show(oid)[STDOUT]
+- self.failUnless(content.startswith('commit '))
+-
+ def test_stdout(self):
+ """Test overflowing the stdout buffer"""
+ # Write to stdout only
diff --git a/dev-vcs/git-cola/git-cola-2.11.ebuild b/dev-vcs/git-cola/git-cola-2.11.ebuild
new file mode 100644
index 000000000000..149e64908a5d
--- /dev/null
+++ b/dev-vcs/git-cola/git-cola-2.11.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1 readme.gentoo-r1 virtualx
+
+DESCRIPTION="The highly caffeinated git GUI"
+HOMEPAGE="https://git-cola.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# Since PyQt5 is preferred at runtime if installed, depend on that
+RDEPEND="
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,network,widgets,${PYTHON_USEDEP}]
+ dev-vcs/git"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ python_targets_python2_7? ( dev-python/sphinxtogithub[$(python_gen_usedep 'python2*')] )
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] ${VIRTUALX_DEPEND} )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.10-disable-live-tests.patch
+)
+
+python_prepare_all() {
+ # Use system QtPy
+ rm -r qtpy || die
+
+ rm share/git-cola/bin/*askpass* || die
+
+ # remove broken tests
+ rm test/i18n_test.py || die
+
+ # don't install docs into wrong location
+ sed -i -e '/doc/d' setup.py || die
+
+ # fix doc directory reference
+ sed -i \
+ -e "s/'doc', 'git-cola'/'doc', '${PF}'/" \
+ cola/resources.py || die
+
+ # fix ssh-askpass directory reference
+ sed -i -e 's/resources\.share/resources\.prefix/' cola/app.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ mydistutilsargs=( --no-vendor-libs )
+}
+
+python_compile_all() {
+ cd share/doc/${PN}/ || die
+ if use doc; then
+ emake all
+ else
+ sed \
+ -e '/^install:/s:install-html::g' \
+ -e '/^install:/s:install-man::g' \
+ -i Makefile || die
+ fi
+}
+
+python_test() {
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" \
+ virtx nosetests --verbose --with-id --with-doctest \
+ --exclude=sphinxtogithub
+}
+
+src_install() {
+ distutils-r1_src_install
+}
+
+python_install_all() {
+ cd share/doc/${PN}/ || die
+ emake \
+ DESTDIR="${D}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
+
+ python_fix_shebang "${ED}/usr/share/git-cola/bin/git-xbase" "${ED}"/usr/bin/git-cola
+ python_optimize "${ED}/usr/share/git-cola/lib/cola"
+
+ use doc || HTML_DOCS=( "${FILESDIR}"/index.html )
+
+ distutils-r1_python_install_all
+ readme.gentoo_create_doc
+}