summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-02-23 15:15:16 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-02-23 15:25:26 +0100
commitad5b8f5830a5e1b8f2ae576b98f852ec9496e62f (patch)
treed20b7032ba130a2ffb9f8cc9c1f397760cdb1077 /dev-vcs
parentdev-vcs/git-lfs: Initial import, bug #548080 (diff)
downloadgentoo-ad5b8f5830a5e1b8f2ae576b98f852ec9496e62f.tar.gz
gentoo-ad5b8f5830a5e1b8f2ae576b98f852ec9496e62f.tar.bz2
gentoo-ad5b8f5830a5e1b8f2ae576b98f852ec9496e62f.zip
dev-vcs/git-lfs: add live ebuild
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-lfs/git-lfs-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/git-lfs-9999.ebuild b/dev-vcs/git-lfs/git-lfs-9999.ebuild
new file mode 100644
index 000000000000..2893dfb5ceea
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGO_PN="github.com/git-lfs/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="command line extension and specification for managing large files with Git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+LICENSE="MIT BSD BSD-2 BSD-4 Apache-2.0"
+SLOT="0"
+IUSE="+doc"
+
+DEPEND="doc? ( app-text/ronn )"
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ # can't use golang-build_src_compile for go generate
+ # and others steps executed by build.go
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go run script/*.go -cmd build || die "build failed"
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin bin/git-lfs
+
+ use doc && doman docs/man/*.1
+}