summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-02 00:18:53 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-02 00:18:53 +0100
commitccd8da73716c237b357a7cd72d880c01b067771b (patch)
tree33c23b97fe9384e150f41e83db1ab7c7b6b182a6 /dev-vcs
parentsys-auth/ykpers: drop 1.20.0 (diff)
downloadgentoo-ccd8da73716c237b357a7cd72d880c01b067771b.tar.gz
gentoo-ccd8da73716c237b357a7cd72d880c01b067771b.tar.bz2
gentoo-ccd8da73716c237b357a7cd72d880c01b067771b.zip
dev-vcs/pre-commit: drop 2.19.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.19.0.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 99ed099e2246..06a74933c9d1 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,2 +1 @@
-DIST pre-commit-2.19.0.tar.gz 266117 BLAKE2B d2105fb9aa64e63c7d93142228545e3597eb4a1637f850ce5d3f14b0826bdfb8a8d971779690c4fda6823fa1915fc57f9c86b9ffae48dbe39e7a225123304f5c SHA512 9cc28c5e9ce4be87e09e7be01138c35bbe954efb6c1400e92b1a6b5f50e426b59d74651802359015840d5ec4a5583bf8f579bf7f08eb778d5950c8c8dfe4c80c
DIST pre-commit-2.20.0.tar.gz 266604 BLAKE2B 470f032e6d5bfcdd9ac8ba8f37d4323b601da0c82bcd524ffc575dc688fe81ad326a1f6a8ddd03da6e37130319ee40070c03d9789cd6e0e4b427a1d6e646416e SHA512 b1da558a0e5d8f2f655427089f1d0b11b01ad7513ece7a0b3b67c33529cf3584edba558c78704e6da6ca18876b1d6c0fa8698e01fd7c2439b8d4dc0a93961e52
diff --git a/dev-vcs/pre-commit/pre-commit-2.19.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.19.0.ebuild
deleted file mode 100644
index 6697add00888..000000000000
--- a/dev-vcs/pre-commit/pre-commit-2.19.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Many test failures with py3.11 as of 2.19.0
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc ~ppc64 x86"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
- ')"
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
-)"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
-# and while some of them do include "skip if not found" logic, most of them do not.
-# The latter consistently fail with
-# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# including with the sandbox disabled and when run manually with tox.
-EPYTEST_DESELECT=(
- tests/languages/
- tests/repository_test.py
- tests/main_test.py::test_all_cmds
- tests/main_test.py::test_try_repo
-)
-
-distutils_enable_tests pytest