summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Vesely <jano.vesely@gmail.com>2016-03-16 08:03:29 -0400
committerRobin H. Johnson <robbat2@gentoo.org>2016-03-22 11:28:50 -0700
commite3ccb028ddbf97cfdadd0a5703d8ed783621dcb2 (patch)
treeff9693cc35ab889525ab92af3467a4baac42564b /dev-vcs
parentdev-lang/rust: change to Rust project (diff)
downloadgentoo-e3ccb028ddbf97cfdadd0a5703d8ed783621dcb2.tar.gz
gentoo-e3ccb028ddbf97cfdadd0a5703d8ed783621dcb2.tar.bz2
gentoo-e3ccb028ddbf97cfdadd0a5703d8ed783621dcb2.zip
dev-vcs/git: Add LINGUAS support
(Sourced from Github PR #1098) X-Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=454584 Signed-off-by: Jan Vesely <jano.vesely@gmail.com> Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.7.4.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-vcs/git/git-2.7.4.ebuild b/dev-vcs/git/git-2.7.4.ebuild
index ff8deaac4d36..06a2a18f46f1 100644
--- a/dev-vcs/git/git-2.7.4.ebuild
+++ b/dev-vcs/git/git-2.7.4.ebuild
@@ -11,8 +11,9 @@ PYTHON_COMPAT=( python2_7 )
[[ ${PV} == *9999 ]] && SCM="git-2"
EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
EGIT_MASTER=pu
+PLOCALES="bg ca de fr is it ko pt_PT ru sv vi zh_CN"
-inherit toolchain-funcs eutils elisp-common perl-module bash-completion-r1 python-single-r1 systemd ${SCM}
+inherit toolchain-funcs eutils elisp-common l10n perl-module bash-completion-r1 python-single-r1 systemd ${SCM}
MY_PV="${PV/_rc/.rc}"
MY_P="${PN}-${MY_PV}"
@@ -534,6 +535,14 @@ src_install() {
fi
perl_delete_localpod
+
+ # Remove disabled linguas
+ # we could remove sources in src_prepare, but install does not
+ # handle missing locale dir well
+ rm_loc() {
+ rm -r "${ED}/usr/share/locale/${1}" || die
+ }
+ l10n_for_each_disabled_locale_do rm_loc
}
src_test() {