summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-07-02 15:59:44 +0200
committerEttore Di Giacinto <mudler@gentoo.org>2017-07-02 16:15:42 +0200
commite9ab2b8003fcc58e9ba8708cfab804f856490f4e (patch)
tree26e84ace7b47d662978671a49a5e15bd3aced3cc /dev-vcs
parentdev-vcs/git-lfs: Drop old (diff)
downloadgentoo-e9ab2b8003fcc58e9ba8708cfab804f856490f4e.tar.gz
gentoo-e9ab2b8003fcc58e9ba8708cfab804f856490f4e.tar.bz2
gentoo-e9ab2b8003fcc58e9ba8708cfab804f856490f4e.zip
dev-vcs/git-lfs: Bump version to 2.2.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-lfs/Manifest1
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.2.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index 96ecdbc6149a..81c50f32bf2c 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1,2 +1,3 @@
DIST git-lfs-1.5.6.tar.gz 604139 SHA256 4efbc806cde1ea6ab4e1d61db3e1f6939796fd53bf6e9c94ac564610147ea5cd SHA512 f5f2da9ac44647335b25cad3104027cf5476e25ef9763019744123f9e1ef81edadbf5b08a146b8070487b32a18aa202c799f910aee6f2f0144ca411ad6d7cfd2 WHIRLPOOL 2f785abffc917a322fe59f4354980d5f565572620569b9b53e85ecdf84b5d7ad407ced8853c897814daa816cac6efd1f85c9098cae9fe48b179cd3381c5f840d
DIST git-lfs-2.1.1.tar.gz 649611 SHA256 655c1e9bf931afb958c2b81de5c1c38b3ebd6831a04ca5fdcf58cba05e2948d8 SHA512 9061cb9fdf93a0c119d5762ceebdbc0573491dedb1815512e7eae9da54574087c1e499ea97ba0a87d7356499314beb53d60d1800b5c85983ef835dae37e7dd84 WHIRLPOOL 0cfbb0912314ca1afbb426b73521c136d35d2da37ee71cc5a952b17ed0bc92b7706483923f2a701f0bfef1407c34b3f4f5f85f97a655efb7f4d3caf615a0c380
+DIST git-lfs-2.2.0.tar.gz 713863 SHA256 d2a30b2e77510d0dc6a050f814909325879d9d8c7dde9eb5664486abdd0411e5 SHA512 2fa2136b933576aefbc2f9fab84c4f7d990b94f96129a9d02085aff397abb8e7a614747a656803e52ccb5fda4e17fcb685c4501fc81855953132efd010e54341 WHIRLPOOL a720601be197a2840cc36dadf469e1828bb69019e1b9287ee2497b46bafad111ca027c53186d17d36be3ee2f6f62a14bff41e08ca2abe890aa5708d98b57d4e8
diff --git a/dev-vcs/git-lfs/git-lfs-2.2.0.ebuild b/dev-vcs/git-lfs/git-lfs-2.2.0.ebuild
new file mode 100644
index 000000000000..7a32ca36cc92
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-2.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/git-lfs/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="command line extension and specification for managing large files with Git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+LICENSE="MIT BSD BSD-2 BSD-4 Apache-2.0"
+SLOT="0"
+IUSE="+doc"
+
+# since version 2.0.2 git-lfs uses time.Until that was introduced in golang >=1.8
+# https://github.com/golang/go/commit/67ea710792eabdae1182e2bf4845f512136cccce
+DEPEND=">=dev-lang/go-1.8.1:=
+ doc? ( app-text/ronn )"
+
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ # can't use golang-build_src_compile for go generate
+ # and others steps executed by build.go
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go run script/*.go -cmd build || die "build failed"
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin bin/git-lfs
+
+ use doc && doman docs/man/*.1
+}