summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2016-03-29 20:47:32 +0200
committerDirkjan Ochtman <djc@gentoo.org>2016-03-29 20:49:46 +0200
commitf099500ae1d3f1380776383c17be5156972b1456 (patch)
tree9c80ee9675ceb90a6126d0bd11e08059f7f5ee9c /dev-vcs
parentdev-python/oslo-policy: bup (diff)
downloadgentoo-f099500ae1d3f1380776383c17be5156972b1456.tar.gz
gentoo-f099500ae1d3f1380776383c17be5156972b1456.tar.bz2
gentoo-f099500ae1d3f1380776383c17be5156972b1456.zip
dev-vcs/mercurial: version bump to 3.7.3
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/Manifest1
-rw-r--r--dev-vcs/mercurial/mercurial-3.7.3.ebuild140
2 files changed, 141 insertions, 0 deletions
diff --git a/dev-vcs/mercurial/Manifest b/dev-vcs/mercurial/Manifest
index 8a3d3062285e..b200f866eba4 100644
--- a/dev-vcs/mercurial/Manifest
+++ b/dev-vcs/mercurial/Manifest
@@ -5,3 +5,4 @@ DIST mercurial-3.5.2.tar.gz 4415307 SHA256 23fdc038503911b21dc9e556118803f7b1d41
DIST mercurial-3.6.3.tar.gz 4521749 SHA256 402731f27256beb9a575a6991ca3d7059976197c905337f4f5729fd940329fa8 SHA512 e5b39e5456a35e19f2ac02838946305023de957590c5aa2828f7c37e9b5f6f2e6376526d0845ebd1ca198860425d11e208b3c36e12e189e0b02871e9c91aad9a WHIRLPOOL 36f0f6caa43ce2c65c7c2bdfb3fa3935cec1e47c25fae6a6a3c7b00165d1aff9b71c73dd10faad2e2ba096d55cc633366170135d95452c162936fef93571dbf1
DIST mercurial-3.7.1.tar.gz 4630846 SHA256 96d37d1f444a032295e190318b3166e9d05abb55916d2b3adb618a8f16c5cfed SHA512 32df161756d7c76abd792bfe5dc3d3f2ea39facdc9c9bd8d93193ecd6cc171f050a4e6dae18255614087ba6fa8f9d787aac41b137c233fa9c3f32217a9cad112 WHIRLPOOL 894a9bd7c61f6a6262ec46f8c80b1894348f765216159458795210fed504a4700e8b4b263e305f3c746d180ef27ab1de11fd4926a2969883d529a613dc93e17a
DIST mercurial-3.7.2.tar.gz 4634748 SHA256 5ba9438d6ab0db93f7b0786ba632138eb64a9dc0d93e30dde2b17b328fdc6d7a SHA512 573b35052ec50f4672cdd5afd93080edc864deb854b890c8cedba53c40d6d3a37a560e364b94b819cfc6d9fc5c07c0411a13167f0888007e5c9366bc94154306 WHIRLPOOL 782a80d5ee09b6868f9da62ff5e7733e8431323ab7adc8fae52ec0d3e43e88c6ef9cdc90bcb61481e971acf60e43965216f414ed9e88dd9f09546d86561baabc
+DIST mercurial-3.7.3.tar.gz 4636732 SHA256 c099c42d74e2d520b61dd372cd996b0fa7605c06617834fd7b13c79b9a9a5b30 SHA512 7f9f97229e40c7092c16ccf227b19a08a9839d8ce19a9d057341fff75876bff32241ee9aa10eab293f779ea3e8a1d97577597187bd96251fb499cbb1075a82cf WHIRLPOOL 51d7f152a0af27924fec8b39933796f5584867efff7f271147139e740302d05f8976f3c2aa95cb724b774ba4951040483bb51b02eed1495d8b15012301ba060e
diff --git a/dev-vcs/mercurial/mercurial-3.7.3.ebuild b/dev-vcs/mercurial/mercurial-3.7.3.ebuild
new file mode 100644
index 000000000000..18f93f985ef2
--- /dev/null
+++ b/dev-vcs/mercurial/mercurial-3.7.3.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bugzilla emacs gpg test tk"
+
+RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ gpg? ( app-crypt/gnupg )
+ tk? ( dev-lang/tk )
+ app-misc/ca-certificates"
+DEPEND="emacs? ( virtual/emacs )
+ test? ( app-arch/unzip
+ dev-python/pygments[${PYTHON_USEDEP}] )"
+
+SITEFILE="70${PN}-gentoo.el"
+
+PATCHES=( "${FILESDIR}/${PN}-3.0.1-po_fixes.patch" )
+
+python_prepare_all() {
+ # fix up logic that won't work in Gentoo Prefix (also won't outside in
+ # certain cases), bug #362891
+ sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ strip-flags -ftracer -ftree-vectorize
+ # Note: make it impl-conditional if py3 is supported
+ append-flags -fno-strict-aliasing
+
+ "${PYTHON}" setup.py build_mo || die
+}
+
+python_compile_all() {
+ rm -r contrib/{win32,macosx} || die
+ if use emacs; then
+ cd contrib || die
+ elisp-compile mercurial.el || die "elisp-compile failed!"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newbashcomp contrib/bash_completion hg
+
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh_completion _hg
+
+ rm -f doc/*.?.txt
+ dodoc CONTRIBUTORS
+ cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
+
+ dobin hgeditor
+ dobin contrib/hgk
+ python_foreach_impl python_doscript contrib/hg-ssh
+
+ if use emacs; then
+ elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
+ *.el mercurial.spec)
+ for f in ${RM_CONTRIB[@]}; do
+ rm -r contrib/$f || die
+ done
+
+ dodoc -r contrib
+ docompress -x /usr/share/doc/${PF}/contrib
+ doman doc/*.?
+
+ cat > "${T}/80mercurial" <<-EOF
+HG="${EPREFIX}/usr/bin/hg"
+EOF
+ doenvd "${T}/80mercurial"
+
+ insinto /etc/mercurial/hgrc.d
+ doins "${FILESDIR}/cacerts.rc"
+}
+
+src_test() {
+ pushd tests &>/dev/null || die
+ rm -rf *svn* # Subversion tests fail with 1.5
+ rm -f test-archive* # Fails due to verbose tar output changes
+ rm -f test-convert-baz* # GNU Arch baz
+ rm -f test-convert-cvs* # CVS
+ rm -f test-convert-darcs* # Darcs
+ rm -f test-convert-git* # git
+ rm -f test-convert-mtn* # monotone
+ rm -f test-convert-tla* # GNU Arch tla
+ #rm -f test-doctest* # doctest always fails with python 2.5.x
+ rm -f test-largefiles* # tends to time out
+
+ popd &>/dev/null || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local TEST_DIR
+
+ rm -rf "${TMPDIR}"/test
+ distutils_install_for_testing
+ cd tests || die
+ "${PYTHON}" run-tests.py --verbose \
+ --tmpdir="${TMPDIR}"/test \
+ --with-hg="${TEST_DIR}"/scripts/hg \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ elog "If you want to convert repositories from other tools using convert"
+ elog "extension please install correct tool:"
+ elog " dev-vcs/cvs"
+ elog " dev-vcs/darcs"
+ elog " dev-vcs/git"
+ elog " dev-vcs/monotone"
+ elog " dev-vcs/subversion"
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}