summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-30 19:13:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-01 20:50:50 +0200
commitba0067d9fd8c099bb16bb3c771f37be8fd323f31 (patch)
treecb0ec5dcd747e925321487c47137eb4660934cd7 /eclass/cmake.eclass
parentcmake.eclass: cmake_run_in: New function (diff)
downloadgentoo-ba0067d9fd8c099bb16bb3c771f37be8fd323f31.tar.gz
gentoo-ba0067d9fd8c099bb16bb3c771f37be8fd323f31.tar.bz2
gentoo-ba0067d9fd8c099bb16bb3c771f37be8fd323f31.zip
cmake.eclass: cmake_comment_add_subdirectory: line length reduction
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'eclass/cmake.eclass')
-rw-r--r--eclass/cmake.eclass17
1 files changed, 9 insertions, 8 deletions
diff --git a/eclass/cmake.eclass b/eclass/cmake.eclass
index 5ea1bd125c74..5505fd21ac0c 100644
--- a/eclass/cmake.eclass
+++ b/eclass/cmake.eclass
@@ -169,16 +169,17 @@ cmake_run_in() {
# Comment out one or more add_subdirectory calls in CMakeLists.txt in the current directory
cmake_comment_add_subdirectory() {
if [[ -z ${1} ]]; then
- die "comment_add_subdirectory must be passed at least one directory name to comment"
+ die "${FUNCNAME[0]} must be passed at least one directory name to comment"
fi
- if [[ -e "CMakeLists.txt" ]]; then
- local d
- for d in $@; do
- sed -e "/add_subdirectory[[:space:]]*([[:space:]]*${d//\//\\/}[[:space:]]*)/I s/^/#DONOTCOMPILE /" \
- -i CMakeLists.txt || die "failed to comment add_subdirectory(${d})"
- done
- fi
+ [[ -e "CMakeLists.txt" ]] || return
+
+ local d
+ for d in $@; do
+ d=${d//\//\\/}
+ sed -e "/add_subdirectory[[:space:]]*([[:space:]]*${d}[[:space:]]*)/I s/^/#DONOTCOMPILE /" \
+ -i CMakeLists.txt || die "failed to comment add_subdirectory(${d})"
+ done
}
# @FUNCTION: comment_add_subdirectory