summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-04 21:57:58 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 21:17:40 +0100
commit13cd1e51ec36a08c4a8ce510782109d7567c28ba (patch)
tree403823f51c6521e3220a6194fe7c49eb87095952 /eclass/distutils-r1.eclass
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.200,4.9.200,4.14.1... (diff)
downloadgentoo-13cd1e51ec36a08c4a8ce510782109d7567c28ba.tar.gz
gentoo-13cd1e51ec36a08c4a8ce510782109d7567c28ba.tar.bz2
gentoo-13cd1e51ec36a08c4a8ce510782109d7567c28ba.zip
distutils-r1.eclass: Add distutils_enable_tests to ease testing
Add a helpful function to handle adding common stuff for the most common test runners. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass60
1 files changed, 60 insertions, 0 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index d3eb8f22ead2..2edffdb2d7c5 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -232,6 +232,66 @@ fi
# }
# @CODE
+# @FUNCTION: distutils_enable_tests
+# @USAGE: <test-runner>
+# @DESCRIPTION:
+# Set up IUSE, RESTRICT, BDEPEND and python_test() for running tests
+# with the specified test runner. Also copies the current value
+# of RDEPEND to test?-BDEPEND. The test-runner argument must be one of:
+#
+# - nose: nosetests (dev-python/nose)
+# - pytest: dev-python/pytest
+# - unittest: for built-in Python unittest module
+#
+# This function is meant as a helper for common use cases, and it only
+# takes care of basic setup. You still need to list additional test
+# dependencies manually. If you have uncommon use case, you should
+# not use it and instead enable tests manually.
+#
+# This function must be called in global scope, after RDEPEND has been
+# declared. Take care not to overwrite the variables set by it.
+distutils_enable_tests() {
+ debug-print-function ${FUNCNAME} "${@}"
+ [[ ${#} -eq 1 ]] || die "${FUNCNAME} takes exactly one argument: test-runner"
+
+ [[ ${EAPI} == [56] ]] && local BDEPEND
+
+ IUSE+=" test"
+ RESTRICT+=" !test? ( test )"
+ BDEPEND+=" test? ("
+
+ case ${1} in
+ nose)
+ BDEPEND+=" dev-python/nose[${PYTHON_USEDEP}]"
+ python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+ }
+ ;;
+ pytest)
+ BDEPEND+=" dev-python/pytest[${PYTHON_USEDEP}]"
+ python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+ }
+ ;;
+ unittest)
+ python_test() {
+ "${EPYTHON}" -m unittest discover -v ||
+ die "Tests fail with ${EPYTHON}"
+ }
+ ;;
+ *)
+ die "${FUNCNAME}: unsupported argument: ${1}"
+ esac
+
+ BDEPEND+=" ${RDEPEND} )"
+
+ [[ ${EAPI} == [56] ]] && DEPEND+=" ${BDEPEND}"
+
+ # we need to ensure successful return in case we're called last,
+ # otherwise Portage may wrongly assume sourcing failed
+ return 0
+}
+
# @FUNCTION: esetup.py
# @USAGE: [<args>...]
# @DESCRIPTION: