summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-18 22:44:54 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-28 20:09:06 +0100
commitd8ec6c80675ccfb046ba5aaf29fc2f245ed0acbd (patch)
tree1e7fc2bf2cdb759185e597c017ef3fbc39fa3a04 /eclass/distutils-r1.eclass
parentdistutils-r1.eclass: esetup.py, respect nonfatal in EAPI 6 (diff)
downloadgentoo-d8ec6c80675ccfb046ba5aaf29fc2f245ed0acbd.tar.gz
gentoo-d8ec6c80675ccfb046ba5aaf29fc2f245ed0acbd.tar.bz2
gentoo-d8ec6c80675ccfb046ba5aaf29fc2f245ed0acbd.zip
distutils-r1.eclass: Use default_src_prepare to apply patches in EAPI 6
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass9
1 files changed, 6 insertions, 3 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 256c893f3b17..f9cff5cc35e5 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -312,9 +312,12 @@ _distutils-r1_disable_ez_setup() {
distutils-r1_python_prepare_all() {
debug-print-function ${FUNCNAME} "${@}"
- [[ ${PATCHES} ]] && epatch "${PATCHES[@]}"
-
- epatch_user
+ if [[ ${EAPI} != [45] ]]; then
+ default
+ else
+ [[ ${PATCHES} ]] && epatch "${PATCHES[@]}"
+ epatch_user
+ fi
# by default, use in-source build if python_prepare() is used
if [[ ! ${DISTUTILS_IN_SOURCE_BUILD+1} ]]; then