summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-28 14:33:36 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-07 15:36:24 +0100
commitf981af79945e28a40dab2b5196329f7835afe78b (patch)
treeba5488e34bf730aeb59c70747afa4c6632f8c2e7 /eclass/git-r3.eclass
parentskel.ebuild: Reorder S after SRC_URI (diff)
downloadgentoo-f981af79945e28a40dab2b5196329f7835afe78b.tar.gz
gentoo-f981af79945e28a40dab2b5196329f7835afe78b.tar.bz2
gentoo-f981af79945e28a40dab2b5196329f7835afe78b.zip
git-r3.eclass: Explicitly disable password prompts
Closes: https://bugs.gentoo.org/701276 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass/git-r3.eclass')
-rw-r--r--eclass/git-r3.eclass3
1 files changed, 3 insertions, 0 deletions
diff --git a/eclass/git-r3.eclass b/eclass/git-r3.eclass
index b1c7f7f43abc..e0d2bbb5edc0 100644
--- a/eclass/git-r3.eclass
+++ b/eclass/git-r3.eclass
@@ -556,6 +556,9 @@ _git-r3_is_local_repo() {
git-r3_fetch() {
debug-print-function ${FUNCNAME} "$@"
+ # disable password prompts, https://bugs.gentoo.org/701276
+ local -x GIT_TERMINAL_PROMPT=0
+
# process repos first since we create repo_name from it
local repos
if [[ ${1} ]]; then