summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-31 05:32:17 +0100
committerSam James <sam@gentoo.org>2021-03-31 06:19:54 +0100
commite5d93414c75747792ecc5125edddefc3dc3f0faf (patch)
treed78c4e3072aa2ed35c10081d4ea787279d253e9d /eclass/xorg-2.eclass
parentant-tasks.eclass: mark ANT_TASK_DEPNAME as @PRE_INHERIT (diff)
downloadgentoo-e5d93414c75747792ecc5125edddefc3dc3f0faf.tar.gz
gentoo-e5d93414c75747792ecc5125edddefc3dc3f0faf.tar.bz2
gentoo-e5d93414c75747792ecc5125edddefc3dc3f0faf.zip
xorg-2.eclass: set various variables as @PRE_INHERIT
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'eclass/xorg-2.eclass')
-rw-r--r--eclass/xorg-2.eclass6
1 files changed, 6 insertions, 0 deletions
diff --git a/eclass/xorg-2.eclass b/eclass/xorg-2.eclass
index 21b3da5374a9..e6ec80523ae2 100644
--- a/eclass/xorg-2.eclass
+++ b/eclass/xorg-2.eclass
@@ -43,6 +43,7 @@ if [[ ${CATEGORY} = media-fonts ]]; then
fi
# @ECLASS-VARIABLE: XORG_MULTILIB
+# @PRE_INHERIT
# @DESCRIPTION:
# If set to 'yes', the multilib support for package will be enabled. Set
# before inheriting this eclass.
@@ -68,18 +69,21 @@ EXPORT_FUNCTIONS ${EXPORTED_FUNCTIONS}
IUSE=""
# @ECLASS-VARIABLE: XORG_EAUTORECONF
+# @PRE_INHERIT
# @DESCRIPTION:
# If set to 'yes' and configure.ac exists, eautoreconf will run. Set
# before inheriting this eclass.
: ${XORG_EAUTORECONF:="no"}
# @ECLASS-VARIABLE: XORG_BASE_INDIVIDUAL_URI
+# @PRE_INHERIT
# @DESCRIPTION:
# Set up SRC_URI for individual modular releases. If set to an empty
# string, no SRC_URI will be provided by the eclass.
: ${XORG_BASE_INDIVIDUAL_URI="https://www.x.org/releases/individual"}
# @ECLASS-VARIABLE: XORG_MODULE
+# @PRE_INHERIT
# @DESCRIPTION:
# The subdirectory to download source from. Possible settings are app,
# doc, data, util, driver, font, lib, proto, xserver. Set above the
@@ -99,6 +103,7 @@ if [[ ${XORG_MODULE} == auto ]]; then
fi
# @ECLASS-VARIABLE: XORG_PACKAGE_NAME
+# @PRE_INHERIT
# @DESCRIPTION:
# For git checkout the git repository might differ from package name.
# This variable can be used for proper directory specification
@@ -148,6 +153,7 @@ if [[ ${FONT} == yes ]]; then
>=x11-apps/mkfontscale-1.2.0"
# @ECLASS-VARIABLE: FONT_DIR
+ # @PRE_INHERIT
# @DESCRIPTION:
# If you're creating a font package and the suffix of PN is not equal to
# the subdirectory of /usr/share/fonts/ it should install into, set