summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-19 18:15:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-04 21:36:08 +0200
commit3b5582636d219284037ee65bc427194d7e969c4b (patch)
treefb740758d0046b5f141ee464cb5a30aba5d95692 /eclass
parentcmake-utils.eclass: Fix typo (diff)
downloadgentoo-3b5582636d219284037ee65bc427194d7e969c4b.tar.gz
gentoo-3b5582636d219284037ee65bc427194d7e969c4b.tar.bz2
gentoo-3b5582636d219284037ee65bc427194d7e969c4b.zip
cmake-utils.eclass: _cmake_modify-cmakelists: Fix CMAKE_BUILD_TYPE sed
Commit 6b7998b narrowed matching CMAKE_BUILD_TYPE too successfully and led to a string like `set(CMAKE_BUILD_TYPE)` being left over. Bug: https://bugs.gentoo.org/674768 Closes: https://bugs.gentoo.org/686266 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/cmake-utils.eclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index 28dac7e0a0b4..ea1858e9735f 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -420,7 +420,7 @@ _cmake_modify-cmakelists() {
# Comment out all set (<some_should_be_user_defined_variable> value)
find "${CMAKE_USE_DIR}" -name CMakeLists.txt -exec sed \
- -e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_BUILD_TYPE[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \
+ -e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_BUILD_TYPE\([[:space:]].*)\|)\)/I{s/^/#_cmake_modify_IGNORE /g}' \
-e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_COLOR_MAKEFILE[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \
-e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_INSTALL_PREFIX[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \
-e '/^[[:space:]]*set[[:space:]]*([[:space:]]*CMAKE_VERBOSE_MAKEFILE[[:space:]].*)/I{s/^/#_cmake_modify_IGNORE /g}' \