summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-02-01 13:31:39 -0500
committerBrian Evans <grknight@gentoo.org>2017-02-01 13:31:39 -0500
commit4db353aa3ab0c41c887d3d745c6cd792c2a97351 (patch)
tree60950645fdde78b125d6ff8e732a9e0ee1c9cd21 /eclass
parentx11-wm/xpra: do not interfere with '--param key=value' gcc args (bug 607776, ... (diff)
downloadgentoo-4db353aa3ab0c41c887d3d745c6cd792c2a97351.tar.gz
gentoo-4db353aa3ab0c41c887d3d745c6cd792c2a97351.tar.bz2
gentoo-4db353aa3ab0c41c887d3d745c6cd792c2a97351.zip
eclass/mysql-multilib-r1: Ignore building SELinux policies for mysqld_safe wrt #607928
Diffstat (limited to 'eclass')
-rw-r--r--eclass/mysql-multilib-r1.eclass11
1 files changed, 7 insertions, 4 deletions
diff --git a/eclass/mysql-multilib-r1.eclass b/eclass/mysql-multilib-r1.eclass
index ebf89f28f94f..b787542745d7 100644
--- a/eclass/mysql-multilib-r1.eclass
+++ b/eclass/mysql-multilib-r1.eclass
@@ -319,12 +319,10 @@ mysql-multilib-r1_src_prepare() {
if in_iuse tokudb ; then
# Don't build bundled xz-utils
if [[ -d "${S}/storage/tokudb/ft-index" ]] ; then
- rm -f "${S}/storage/tokudb/ft-index/cmake_modules/TokuThirdParty.cmake" || die
- touch "${S}/storage/tokudb/ft-index/cmake_modules/TokuThirdParty.cmake" || die
+ echo > "${S}/storage/tokudb/ft-index/cmake_modules/TokuThirdParty.cmake" || die
sed -i 's/ build_lzma//' "${S}/storage/tokudb/ft-index/ft/CMakeLists.txt" || die
elif [[ -d "${S}/storage/tokudb/PerconaFT" ]] ; then
- rm "${S}/storage/tokudb/PerconaFT/cmake_modules/TokuThirdParty.cmake" || die
- touch "${S}/storage/tokudb/PerconaFT/cmake_modules/TokuThirdParty.cmake" || die
+ echo > "${S}/storage/tokudb/PerconaFT/cmake_modules/TokuThirdParty.cmake" || die
sed -i -e 's/ build_lzma//' -e 's/ build_snappy//' "${S}/storage/tokudb/PerconaFT/ft/CMakeLists.txt" || die
sed -i -e 's/add_dependencies\(tokuportability_static_conv build_jemalloc\)//' "${S}/storage/tokudb/PerconaFT/portability/CMakeLists.txt" || die
fi
@@ -340,6 +338,11 @@ mysql-multilib-r1_src_prepare() {
rm -r "${S}"/storage/mroonga/vendor/groonga || die "could not remove packaged groonga"
fi
+ # Remove the centos and rhel selinux policies to support mysqld_safe under SELinux
+ if [[ -d "${S}/support-files/SELinux" ]] ; then
+ echo > "${S}/support-files/SELinux/CMakeLists.txt" || die
+ fi
+
if [[ "${EAPI}x" == "5x" ]] ; then
epatch_user
else