summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-03-11 06:03:57 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-03-13 04:00:30 +1100
commitd0631022fe1b0bc3d4990fc809d57d720070eab3 (patch)
tree7a3a67eee7f53ab5a80c2a1438e5c7961ef79356 /eclass
parentkde5-functions.eclass: Drop KDEBASE for other than kdevelop (diff)
downloadgentoo-d0631022fe1b0bc3d4990fc809d57d720070eab3.tar.gz
gentoo-d0631022fe1b0bc3d4990fc809d57d720070eab3.tar.bz2
gentoo-d0631022fe1b0bc3d4990fc809d57d720070eab3.zip
kde5-functions.eclass: improve punt_bogus_deps
This extends coverage to individual components such as find_package(KF5DocTools). It also improves cleaning up of empty find_package calls such as find_package(KF5).
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde5-functions.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/kde5-functions.eclass b/eclass/kde5-functions.eclass
index 0a6a4347c613..34a7c9244157 100644
--- a/eclass/kde5-functions.eclass
+++ b/eclass/kde5-functions.eclass
@@ -260,7 +260,7 @@ punt_bogus_dep() {
local prefix=${1}
local dep=${2}
- pcregrep -Mni "(?s)find_package\s*\(\s*${prefix}.[^)]*?${dep}.*?\)" CMakeLists.txt > "${T}/bogus${dep}"
+ pcregrep -Mni "(?s)find_package\s*\(\s*${prefix}[^)]*?${dep}.*?\)" CMakeLists.txt > "${T}/bogus${dep}"
# pcregrep returns non-zero on no matches/error
if [[ $? != 0 ]] ; then
@@ -274,7 +274,7 @@ punt_bogus_dep() {
sed -e "${first},${last}s/${dep}//" -i CMakeLists.txt || die
if [[ ${length} = 1 ]] ; then
- sed -e "/find_package\s*(\s*${prefix}\s*REQUIRED\s*COMPONENTS\s*)/I d" -i CMakeLists.txt || die
+ sed -e "/find_package\s*(\s*${prefix}\s*\(REQUIRED\)*\s*\(COMPONENTS\)*\s*)/I d" -i CMakeLists.txt || die
fi
}