summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-10-01 16:06:30 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-10-01 16:07:35 +0200
commitd16ccc65a2d379ee6e829c007bbed2a10c291cd8 (patch)
tree5acce3d0a6169168c239d409037f80aa1c353a7a /eclass
parentapache-2.eclass: Added missing "|| die" statements (diff)
downloadgentoo-d16ccc65a2d379ee6e829c007bbed2a10c291cd8.tar.gz
gentoo-d16ccc65a2d379ee6e829c007bbed2a10c291cd8.tar.bz2
gentoo-d16ccc65a2d379ee6e829c007bbed2a10c291cd8.zip
apache-2.eclass: Removed EAPI-5 support
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/apache-2.eclass29
1 files changed, 6 insertions, 23 deletions
diff --git a/eclass/apache-2.eclass b/eclass/apache-2.eclass
index 17301c36f8b8..07f2cd6af875 100644
--- a/eclass/apache-2.eclass
+++ b/eclass/apache-2.eclass
@@ -4,7 +4,7 @@
# @ECLASS: apache-2.eclass
# @MAINTAINER:
# polynomial-c@gentoo.org
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 6 7
# @BLURB: Provides a common set of functions for apache-2.x ebuilds
# @DESCRIPTION:
# This eclass handles apache-2.x ebuild functions such as LoadModule generation
@@ -16,8 +16,8 @@ inherit autotools flag-o-matic multilib ssl-cert user toolchain-funcs eapi7-ver
&& die "Do not use this eclass with anything else than www-servers/apache ebuilds!"
case ${EAPI:-0} in
- 0|1|2|3|4)
- die "This eclass is banned for EAPI<5"
+ 0|1|2|3|4|5)
+ die "This eclass is banned for EAPI<6"
;;
esac
@@ -452,29 +452,12 @@ apache-2_src_prepare() {
"${GENTOO_PATCHDIR}"/{conf/httpd.conf,init/*,patches/config.layout} \
|| die "libdir sed failed"
- if [[ "${EAPI}" -ge 6 ]] ; then
- default
- eapply "${GENTOO_PATCHDIR}"/patches/*.patch
- else
- epatch "${GENTOO_PATCHDIR}"/patches/*.patch
- fi
-
- if [[ ${EAPI} = 5 ]] ; then
- # Handle patches from ebuild's PATCHES array if one is given
- if [[ -n "${PATCHES}" ]] ; then
- local patchestype=$(declare -p PATCHES 2>&-)
- if [[ "${patchestype}" != "declare -a PATCHES="* ]] ; then
- die "Declaring PATCHES as a variable is forbidden. Please use an array instead."
- fi
- epatch "${PATCHES[@]}"
- fi
-
- # Handle user patches
- epatch_user
- fi
+ eapply "${GENTOO_PATCHDIR}"/patches/*.patch
+ default
# Don't rename configure.in _before_ any possible user patches!
if [[ -f "configure.in" ]] ; then
+ elog "Renaming configure.in to configure.ac"
mv configure.{in,ac} || die
fi