summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-08-01 03:51:36 -0500
committerMichał Górny <mgorny@gentoo.org>2018-08-15 12:32:49 +0200
commit591dc73d8ec764f6e5c0b8b8a5fd93baeaccbd26 (patch)
tree544579f5b78de7771fba8ba798e43295bf17cea7 /games-action/barrage
parentgames-action/barrage: eutils->desktop (diff)
downloadgentoo-591dc73d8ec764f6e5c0b8b8a5fd93baeaccbd26.tar.gz
gentoo-591dc73d8ec764f6e5c0b8b8a5fd93baeaccbd26.tar.bz2
gentoo-591dc73d8ec764f6e5c0b8b8a5fd93baeaccbd26.zip
games-action/barrage: add missing gnome2-utils
ebuild exhibits qa issues due to installing icons without updating the icon cache. Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'games-action/barrage')
-rw-r--r--games-action/barrage/barrage-1.0.4-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/games-action/barrage/barrage-1.0.4-r1.ebuild b/games-action/barrage/barrage-1.0.4-r1.ebuild
index 8bf934170cb1..3f7e63b9a76e 100644
--- a/games-action/barrage/barrage-1.0.4-r1.ebuild
+++ b/games-action/barrage/barrage-1.0.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit desktop
+inherit desktop gnome2-utils
DESCRIPTION="A violent point-and-click shooting game"
HOMEPAGE="http://lgames.sourceforge.net/Barrage/"
@@ -26,3 +26,11 @@ src_install() {
make_desktop_entry ${PN} Barrage
rm "${ED%/}"/usr/share/applications/${PN}.desktop || die
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}