summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-10-31 21:00:16 +0100
committerTupone Alfredo <tupone@gentoo.org>2017-10-31 21:00:16 +0100
commit40de8499e9897764a20749052cce6a1ac4086f5e (patch)
treef7375f4baf66febe1d0db8f12788ee7bf27d159e /games-action/bzflag/bzflag-2.4.12.ebuild
parentdev-python/cryptography: allow the new ecc enabled openssl (got around patent... (diff)
downloadgentoo-40de8499e9897764a20749052cce6a1ac4086f5e.tar.gz
gentoo-40de8499e9897764a20749052cce6a1ac4086f5e.tar.bz2
gentoo-40de8499e9897764a20749052cce6a1ac4086f5e.zip
games-action/bzflag: Version bump to 2.4.12
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'games-action/bzflag/bzflag-2.4.12.ebuild')
-rw-r--r--games-action/bzflag/bzflag-2.4.12.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/games-action/bzflag/bzflag-2.4.12.ebuild b/games-action/bzflag/bzflag-2.4.12.ebuild
new file mode 100644
index 000000000000..909cc8440797
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.4.12.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="http://www.bzflag.org/"
+SRC_URI="https://download.bzflag.org/bzflag/source/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated upnp"
+
+DEPEND="
+ net-dns/c-ares
+ >=net-misc/curl-7.15.0
+ sys-libs/ncurses:0
+ sys-libs/zlib
+ !dedicated? (
+ media-libs/libsdl2[joystick,sound,video]
+ virtual/glu
+ virtual/opengl )
+ upnp? ( net-libs/miniupnpc )"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-configure.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use dedicated ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf="--disable-client --without-SDL"
+ fi
+
+ econf \
+ $(use_enable upnp UPnP) \
+ ${myconf}
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog DEVINFO PORTING README README.Linux" \
+ default
+
+ if ! use dedicated ; then
+ newicon data/bzflag-48x48.png ${PN}.png
+ make_desktop_entry ${PN} "BZFlag"
+ fi
+
+ prune_libtool_files --modules
+}