summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-04-25 14:34:04 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-04-25 14:34:04 +0200
commit447d777c897ad60ae8344ad91759c35eb1c86261 (patch)
tree7843171fcda20ed6bb05da7a170068c7be24abb9 /games-action/bzflag
parentsys-apps/bat: bump to 0.15.0 (diff)
downloadgentoo-447d777c897ad60ae8344ad91759c35eb1c86261.tar.gz
gentoo-447d777c897ad60ae8344ad91759c35eb1c86261.tar.bz2
gentoo-447d777c897ad60ae8344ad91759c35eb1c86261.zip
games-action/bzflag: version bump to 2.4.20
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'games-action/bzflag')
-rw-r--r--games-action/bzflag/Manifest1
-rw-r--r--games-action/bzflag/bzflag-2.4.20.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/games-action/bzflag/Manifest b/games-action/bzflag/Manifest
index e7fd80891082..26fd4fe4e9bf 100644
--- a/games-action/bzflag/Manifest
+++ b/games-action/bzflag/Manifest
@@ -2,3 +2,4 @@ DIST bzflag-2.4.12.tar.bz2 14042357 BLAKE2B eb18072f459549b18bf99fbe0b635aea2456
DIST bzflag-2.4.14.tar.bz2 14066129 BLAKE2B 7ec44bc9b7ccb644b98dac0b99770471b488b9e34b12a34e4fa76cdc22a4e7b14324915b83db76a69bb4b8ebd928018e69145aa6b87e48a379d37c23ce84c575 SHA512 c092a869813bd300e5eff5bf17ea46708b566a9e4f56cb6c4ccd92346ab1e87c8837efb8295d3b4485cd8d4de5b0d92b079c70390d06a481cfee693d393aca21
DIST bzflag-2.4.16.tar.bz2 14010330 BLAKE2B fc19e068c43c18bd38445b48ca0ca38669f956da1540e3255420cb7f36a42349aa3aa881dfeed2b2a1a7e163ee832a510fde658edd38b6ac038b62229baf8306 SHA512 809adc39088f3fc8ca0d2ead9c7172cfbe582789bc80b3ac55fabe078a0868f0cf7cfa8027ac696718e9983a19386933fd370684a0bd33e63c3106f2ce8a9d63
DIST bzflag-2.4.18.tar.bz2 14011236 BLAKE2B 103495622afb45b2bf87576d92c5cdd37a04386fa82583929ab64087a875acd3be49045cf81d0099fccd0ebc5e7471883756edb85894f9f519d7b6fea8ac3534 SHA512 8e3183f2d78b686c92f3b9911b3cad2fa0df5693401537dc674c75e192fd59451167b7ddc546aa8a090b38d7864b8f22459ba9a4702451987f9c1dfa87fdb246
+DIST bzflag-2.4.20.tar.bz2 14032356 BLAKE2B 278b0f0d970f103a7b00953e60bda6962706dea27a8695bae8e902bdbb1364158ace03dafc778871e89444fe44f16e7d2fceec36b67982ad7f18fc916484260d SHA512 6140123d37065bead3021ef9c36db1210ad2c71a4a7deb6894bb3f856a571197a7eac37d16b8e3b587549dc201c4ac8d7bbe03d1a05d067dc452861924005169
diff --git a/games-action/bzflag/bzflag-2.4.20.ebuild b/games-action/bzflag/bzflag-2.4.20.ebuild
new file mode 100644
index 000000000000..c9e550882ec9
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.4.20.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop flag-o-matic
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="https://www.bzflag.org/"
+SRC_URI="https://download.bzflag.org/bzflag/source/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated upnp"
+
+RDEPEND="
+ net-dns/c-ares
+ >=net-misc/curl-7.15.0
+ sys-libs/ncurses:0
+ sys-libs/zlib
+ !dedicated? (
+ media-libs/libsdl2[joystick,sound,video]
+ media-libs/glew:=
+ virtual/glu
+ virtual/opengl )
+ upnp? ( net-libs/miniupnpc )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.12-configure.patch
+ "${FILESDIR}"/${PN}-2.4.12-tinfo.patch
+ "${FILESDIR}"/${PN}-2.4.12-sdl2-cppflags.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable upnp UPnP)
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/${PN}
+ )
+
+ if use dedicated ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf+=( --disable-client --without-SDL )
+ else
+ myconf=( --with-SDL=2 )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog DEVINFO PORTING README README.Linux" \
+ default
+
+ if ! use dedicated ; then
+ newicon data/bzflag-48x48.png ${PN}.png
+ make_desktop_entry ${PN} "BZFlag"
+ fi
+
+ find "${D}"/ -name \*.la -delete
+}